GE Bug?

The left side of the picture is “Game Engine”, or “Game Mode” and the right side of the picture is “Object Mode”… I clicked P to get into Game Engine and the screen just goes/stays blank. Can’t see anything. I tried changing the colour of the objects, I tried making a new file, and restarting blender, although sometimes when I start blender it works for abit, overall, after like 1-15 minutes it will go back to the blank nothing in Game Engine. Whats wrong with it? :frowning:

Any help is appreciated. :cool:

Do you have an active camera?

Yeah I do. It’s active and can see everything clearly. If I Render it works perfectly, but when I go to Game Engine its just blank. It’s annoying because with that, I can’t do anything :(…

there are at least two more threads about this bug, I guess you have an ATI card, yes? try play around with the settings.

In your image the little shaded cube icon, tell us that you’re in “shaded mode” or the “Textured mode” is necessary for the Game Engine ( Ctrl-Z - Sphere icon).
We can see the camera (activeone?) too, or, in a “normal” situation we see “trough” the camera ( dotted lines view)?!
Select your camera, press Ctrl-NumPad 0, adjuyst your view, and try P again!

Sim88, yeah I do. :P, but almost everything runs on my computers smoothly, why would Blender have any problems? :frowning: Any idea of what settings I should try? I don’t want to stuff anything up, lol.

OTO, thanks, but I think I’ve tried everything with the camera, don’t think thats the problem. :(, here’s another picture of it, still the same problem.

To ensure that there is some rendering in the view:

  • activate “Game -> Show Framerate and Profile” (profile.png)
    Do you see some text with this setting?

  • Other context is visible in BGE? (eg “yo Frankie!”)

  • Only if you have two 3D Views (one for the GE), or the same problem with only one 3D View (than start GE in this view)?


Conz, the Show Framerate and Profile, yeah, theres text. All the numbers etc etc. It seems fine from there.

  • Other context is visible in BGE? (eg “yo Frankie!”)
    Nah, still nothing. :frowning:

Also, I always use two windows, and the problem does the same in both. Either window I click and go to Game Engine its blank.

So its kind of like, everythings working but theres just like a cover over the camera so I can’t see/do anything. It’s so strange. :frowning:

Thanks for everyones help so far.

Post the .blend maybe?!

Camera clipping? Have you negative scaled your camera? Delete the camera… add in a new one… and turn up the clipping distance of the camera to 1000

This has nothing to do with camera clipping or the blend, if it is the same bug I had then it’s the rendering code that doesn’t work with some ATI setting, I don’t know which. When I got a new computer it worked fine. In the last thread about this there was some suggestions…

I have the same problem with dual ATI fire GL5200’s. I grand of video cards and I am brought to my knees by blender still. It works better on my render node with a onboard mobo ATI graphics card!

I have the same problem as well.
I have an ATI card.

It’s really annoying, but if I want to test a game I’m making, I have to restart Blender Every 5-15 minutes.

I had the same problem. ATI Radeon. A couple of weeks ago, I downgraded my drivers. I haven’t had a problem since I did that.

The oldest drivers on the ATI site are the only ones that work without problems for me. I think they are 7-11 drivers. They use OpenGL 2.0. Everything after that uses OpenGL 2.1. And the old drivers more than tripled my frame rate for Blender.

Someone else suggested changing the OpenGL AntiAliasing and OpenGL Anisotropic Filtering from Application Controlled to 2X. They said that worked for them.

I went and got the oldest drivers on the ATI drivers website
My game engine seems to work really well at this point my frames per second is now at 145-150 and it was stuck at 59-60 with the latest drivers from same website. Thank you everyone!! YOu have saved me hours and possibly lots of $$ as well.

It’s because ATI sucks at OpenGL. :frowning:
ATI is so much cheaper than nVidia, in price/quality relationship. ATI works well at DirectX, though.

DBL post sry

ok please i have same problem what exactly did you do i want to do same thing i’m not sure what driver i am using how do i find this and then get oldversion

ahahahahaaaaaaaaaaaaa which one is it whats the official name!!! please help man this is really frustating me YOUR MY LAST HOPE FOR SANITY

please some one i beg of you i beg of you