General help please!

Hello! Super noobie over here and finding myself stumped with almost every part of 2.8 after switching over from learning basics in 2.79. My newest battle has been trying to figure out the zoom in “edit mode”. It sometimes gets stuck where I can only zoom out while other times only allowing me to zoom in. It’s never on any extreme close-up or far away shot either and the problem goes away as soon as I enter back into object mode. Any guidance would be greatly appreciated! Thanks so much!

Try hitting the tilde key, and choose view selected, you should be able to zoom in on the area you want to work on.

You mean not at all? Does it work with ctrl-middle mouse?

That’s strange… is your object really huge? Usually centering the object or a region works for me. Also, did you change any zoom settings in to preferences? I usually set mine to zoom to cursor, but it’s anyone’s preference.

I had inverted the scroll settings but that hasn’t given me any issues- it’s mostly just that i can’t zoom out while in edit mode

Is it object specific or do you have the same issue with a default cube in a clean scene?

It’s with all objects. I just switched back to 2.79 to check that and the zoom works fine. Only seems to be in 2.8

That’s pretty strange… what build are you using? If it’s not related to industry standard keymaps they’re fiddling with lately I’m kinda out of ideas…

Should be the newest one then… was just working with it a few hours ago and didn’t have any problems.

Maybe someone else encountered something similar and has some pointers. Keep us posted if you find a solution, curious to see what was causing it.

1 Like

Hello! I figured out the last issue, I think it was because I had made some changes to the mouse scroll inversion in Windows and then layering with inversion in Blender caused some sort of confusion, thank you for your patience and help though! having one new problem though and hoping you could help. My issue is with the box select, I cannot select multiple meshes by click-dragging over them or even with using the box select shortcut (b), then click-drag. I am able to select a single mesh + light sources with the box select tho- This problem does not carry over to edit mode and I can box select edges or vertices. I’ve tried resetting all of the user preferences but nothing is seeming to fix it. Any help would be greatly appreciated!

To add a little more detail, I can select multiple objects only by holding down shift while clicking on them each individually

That’s a new one. So to clarify, if you start with a fresh scene, create a few boxes neither box select nor “b” select is selecting them? Does it happen both in the default and industry compatible presets? Is it only box select or circle/lasso select as well? I’m guessing the select operation is set to “new”.

This’d be far fetched but sometimes a theme setting would make it hard to see if multiple objects are selected. I can’t really reproduce it so that the drag select still works in edit mode.

1 Like

Yes, Dan. It is on both default and industry presets, also with the 2.7x presets. I just checked and circle select is working fine, it’s just box select is still only selecting one item. Looking for select option but I don’t see anything wonky, using factory presets at this point as well to try and clear things up

Just tried a different mouse and still the same problem- Wondering if it’s with this current upload of 2.8 because it is working fine on my laptop which has a version I downloaded about a week ago.

Ye, that’s what I was about to suggest, try a different build. Last resort could be submitting a bug report ticket.

They’re working on key maps at the moment so there might be some hickups here and there until that’s sorted. Fingers crossed it’ll be soon, can’t wait for them to tackle some new features, bug fixing is so boring… :slight_smile:

1 Like

Resolved! it turns out this is an issue with 2.8 that only happens if you are using a certain series of Intel graphics cards- I have a Geforce that I installed but it was running alongside an integrated card on the Intel processor. I disabled the Intel graphics card and the problem immediately vanished. There is an official bug report on Blender’s development forum.

1 Like