Generation has thrown an exception: Could not generate: Target rig is not visible


I’m relatively new to blender, with my only renders being a rotating donut and a lowpoly world, both following guides.

I decided to follow a tutorial, using it as a base template for learning new things : this time, it was character creation and rigging.

I rig my first character fine using a premade skeleton, which worked. No errors in generating a rig. However, the same could not be said for the one I made next.

It was a custom skeleton I made. Going through the works, I slowly figured out things I did wrong, such as overlapping vertexes and clipping meshes not letting me parent the rigging, etc…

I come to the end of my learning journey thinking I had solved all the problems, when this error appears : Generation has thrown an exception: Could not generate: Target rig is not visible.

I’ve been tinkering around for a solid hour and a half, and when directly searching for the error, there was none on this particular issue.

Thus I am here, begging on my knees for help, with baggy eyes and even baggier brain cells.

(Also, I can’t seem to post any attachments since I’m a new account, so I’ll link it to a video.)

1 Like

Hey there, I’m sorry you’re dealing with this! The Generate Rig button runs a Python script very specifically tied to a Rigify rig. Unless you’re using a Rigify rig, the Generate Rig button won’t do anything, so with a custom rig, it’s not going to work. You could build your own rig generation script, you could just make some controller bones and do it piece by piece, or you can just not worry about the rig and just use the skeleton by itself. It’ll work perfectly, it’s a beautiful skeleton :slight_smile:

1 Like

Wait, so the Generate Rig function only works on the pre-set rigs? I can’t make my own rig to use in conjunction with Generate Rig?

From what I saw with CGDive (by the way, absolute amazing channel for learning rigging in blender), he made his rig custom and it seemed to work.

Here’s the video I’m referring to.

Also, thank you josephhansen for the compliment, it means a lot.

Yes you can generate a rigify rig providing you start with adding the first armature bone deleting it and then in edit mode using the pre created armature body parts from the rigify list.
(3.21 in the video)

1 Like

Aaah, I see. So Rigify detects the preset bones such as arm preset and spine preset, but not custom rigs like the one I made.

I just have to replace every bone in my armature with slightly modified presets and it should work then right?

But wait, when I take a premade armature (basic human), it seems to have the same issue…

Also, thank you so much for your help on this issue digitvisions, I really appreciate it.

1 Like

The reason is that you haven’t cleared the old WGTS. you need to clear all the old bits left over from previous attempt. Or start a new file and it should work.

I’m so dumb. It was even one of the issues I had before that I already solved. A real face palm moment right there.

Thank you so much digitvisions, you’re an awesome bloke!

1 Like

This happens quite often to all of us in 3d. :wink:

1 Like

Now isn’t that the truth.

Thank you to digitvisions and josephhansen for coming to my rescue. Another Blender noob saved yet again!

Hope this post also helps other Blender noobs overcome the same issue!

Hope you all have a nice day!

Ok, status update on the issue.

It seems that maybe its an issue with the python script itself, because using a pre-set rig (meta rig human), even without the WGTS, is still coming up with the same error.

I’m not sure if its because of the fact that I removed the face or what not, but the error is still prevalent.

can you open the advanced options and make a screenshot? and what version of rigify do you use? I know this error from an older version, where you couldn’t generate a rig, that was not visible or selectable. So maybe there is some hiccup with the bobby rig.

Sorry, how do I check the version of rigify, and what advanced options are you talking about?

these I meant. you can define the name of the target rig, wgt collection etc… there

rigify version number can be found in preferences->addons


Yes deleting the face bones could be the reason.
This thread deal with this:
Also the fact that you think you deleted all the face bones but like i found the hard way there is a face bone hiding inside the head bone if you delete that one as well as the rest of the bones that usually fixes it.
See screen shot:

Sorry for the late screenshots ogonek, here they are!

I had already deleted all the face bones (including the one in the spine, I saw it while in wireframe mode).

But it seems the thread that you linked suggested to not delete the face bones, and just disable them. Interesting idea. Thank you for the link digitvisions!

Awesome! I tried out disabling all the face rigging instead of deleting them and it worked! Thank you so much digitvisions for the solution!

Also thank you to ogonek for your help as well!

great that you solved it. my idea would have been to rename the target rig in the advanced settings or select “new” because for me it seems its trying to overwrite the Bobby one (which is set invisible)
Also updating rigify 0.6.6 would be a good idea as there were a few bugs fixed.