Get keyframe on wind strength


I’m a blender beginner and try to work through the manual. Now I’m stuck at the example of Softbodies (the one with the flag in the wind).
Everything works fine until I want to get a changing wind strength over time. The manual just say: “Create an IPO curve on wind strength” but I don’t know how it works. I’ve read every documentation I was able to get but everywhere only LOC, SIZE, etc. keyframes are described.
When I’m in IPO editor and set to object mode the list of parameters on the left hand side contains FStrength, so I thing this is what I need. But when I add a key (IKEY) the menu only gives LOCs, SIZEs, ROTs and the misterious “AVAIL”. When I choose AVAIL nothing happens at all.

Please… how can I get keyframes on parameters not in the IKEY submenu?

Thanx in advance…


and what append if you press IKEY in button window over the wind panel?

You could also just CTRL-left click inside the IPO window (make sure FStrength is selected). Its just like adding a vertex on a mesh! Then, when you are done adding your Keys, go into edit mode (the dots should be purple), and right click them to select them (select the center one to change the point itself, the outer ones to change the drop off settings). Hit the N-key and change your settings in there.

Nothing. The mouse cursor must be in a scene or IPO viewport to use IKEY.

Actually, IKEY can work over any keyframable slider in the interface I believe

I’ve just tried it again. I’m in “Animation” screen layout, moving mouse cursor over wind strength slider an press IKEY. Frameborders are flashing a little bit but nothing happens, no pop up menu, no change in IPO curve or timebar.

Scaling the empty of the wind force also changes the strength. Keyframe the scaling.

No, hit I-Key in the Anim Buttons window (F7).


I’ll try but this is no general solution how to add keyframes for parameters not available in the popup menu.

No, doesn’t work. I’ve tried to use IKEY everywhere on the screen. It just works in a scene window (the “add keyframe” popup appears with LOCs, ROTs, SIZEs and that strange AVAIL) and in the IPO window (a popup appears saying “Add key vertices” and the only option to choose is “current frame”; nothing happens when klicking it…)

and what append if you press IKEY in button window over the wind panel?

No, hit I-Key in the Anim Buttons window (F7).
screenshot is from 2.37.

Please try it first.

No, soory.
The particle/fields panel looks slightly different in 2.41 but no matter where I place the mouse pointer in there nothing happens when pressing IKEY.
Where was your mouse cursor in that screenshot when you pressed IKEY?
Was there a functional change between 2.37 and 2.41 ?

Your mouse cursor must be in the buttons window (F7) and the emitter mesh must be selected with RMB (not box-select). There has been no change to that function.


Believe me, it doesn’t work. Could it be the reason that there is no emitter mesh but only an “Empty” which emits the wind?

My setup: Deleted default cube - Added Empty - Activated wind effect for empty - Switched to Animation screen layout - Selected Empty with RMB - Clicked on FStrength in IPO window to turn it white (don’t know if neccesary) - Moved mouse cursor over the wind strength number field in button window - Pressed IKEY (about 2 dozen times…) - Nothing happens :frowning:

I can confirm that using I-key in the buttons window only works to set field strength for field-emitting meshes, but not for Empties.

Is this done by intention or are the Empties been forgotten for animation?

It looks like an oversight. You can still control the FStrength of a windy Empty by building an IPO curve in the IPO editor as iokua83 describes above, or by keyframing the Empty’s size.

OK, noticed. I’ll try it that way. Maybe the Empties will emancipate in a future version :wink: