Getting A 3dconnexion Device Running In Blender


(VitalBodies) #1

Greetings,
I am trying to get a 3dconnexion Device Running In Blender and could use some help.
Is this the correct forum category for this?
I am also trying to create a blog post to help others who use Ubuntu (Linux).

I think I have the device running using the open source driver but I have not gotten it going in Blender. I am using a SpacePilot.
http://www.3dconnexion.com/products/spacepilot.html

This blog post details my progress so far and the steps I have taken:
http://www.vitalbodies.com/blog/2010/03/09/getting-a-3dconnexion-device-running-in-ubuntu/

I have seen many many forum posts (here, Ubuntu, 3Dconnexions, and elsewhere) of people that did not get the device going or who had odd results if they did. Time has passed and development happens…
Some users seemed to get the device going but did not say how. Some users seemed to need a special edition of Blender from a site that has apparently shut down.

I am using the current 64-bit Blender 2.49 from Ubuntu and the latest open source SpaceNav daemon. Spnavcfg shows the driver is going.

What should happen in Blender - how do I make this go? All help is REALLY appreciated.


(VitalBodies) #2

This is still a current issue if anyone has any insight.


(arexma) #3

Why you try with the open source drivers?
There are fine linux drivers from 3Dc.

Basically all you need (I am running Debian) is:

The driver
3DxWare i386
3DxWare x64
and
The Blender plugin

I guess though with 2.5 we´ll get some new probs =)


(VitalBodies) #4

Thanks for replying.
So what happens when you are in Blender? Does it just work, or do you have to select or load something? What do you do to get the driver going in Blender?
I also wanted to try the open source version as it is likely to get better and better.

As far as I can tell I have the plugin installed. Are you using Gnome, is the plug in the home/user/.blender/plugins folder or elsewhere?

Did you have to remap button in the driver or in Blender?


(arexma) #5

Once the driver is up and running, simply copy the 3DxNdofBlender.plug to the plugins folder in Blender (note that it is not the scripts folder, but the plugin folder, peeps often mistake it)
Next time you fire up Blender, it should just work with the settings you applied in the driver preference window.

Don’t get me wrong, I do love and support open source to the full extend, even with donations, still, when I got something that works good, I don´t use something in the hope to get better and better if I want a stable production environment.
Be egoistic, use whatever works and gets the job done =)

And ty for your sig =) reminded me i wanted to look into AQSIS for some time now =)


(VitalBodies) #6

As far as I can tell I have the plugin installed. Are you using Gnome, is the plug in the home/user/.blender/plugins folder or elsewhere?

Did you have to remap buttons in the driver or in Blender?

Did you do ANYTHING in Blender? Like if you load the default cube and just move the puck on the 3d controller does the cube or camera move? Do you have to be in a certain view like camera? Can you push a button like TOP and the view changes to TOP? Flying blind here…

Would you be willing to help me get this going?
I have TRIED, did you see my blog post?

I started with the proprietary version and could not get that going either.
Might be human error : )


(arexma) #7

Sorry, for the reply lag =)
Busybee.

I use KDE4/XFCE (Desktop/Notebook).
And nope, not the .blender folder.
it should be something like “/home/VitalBodies/blender_2.49a/plugins/”

Once the driver is running and the plugin is in the blender folder you need nothing more to do. It just works. In Blender it uses the axis mapping and thresholds you setup in the driver panel. IIRC (haven´t used my 3Dcx in a while) you can map the buttons within the blender preferences.

I got no time to read your blog yet, hopefully I got time tomorrow, maybe I see the problem… you better get it running, the SpacePilot isn´t exactly a cheap gadged =)


(VitalBodies) #8

Thanks again for your help.
You wrote: “you can map the buttons within the blender preferences.”
Is that to say within Blender or within the MAIN 3Dconnexion Driver?


(arexma) #9

I wrote IIRC (if Iremember correcty) :slight_smile:

However in the 3DcX driver panel you choose what the button is mapped to… LMB/RMB or whatever key.

I am not sure, I am at the moment on a windows machine and havent used my Pilot in a while in Linux now, but again, IIRC, the plugin creates a new entry in the blenders preference view, where you then can map the keys that are bound to buttons of your pilot to actions in blender.
I might be wrong though with latter one.
I´ll check it in the evening when I am on my machine not to be said to be a liar or talespinner :wink:


(arexma) #10

I don´t know for the opensource driver/plugin, however it came back to my mind, the proprietary plugin only works with 32bit Blender.

Judging by your sig I bet you got 64b ubuntu running and 64b blender =)


(VitalBodies) #11

64-bit for sure - with 18GB of ram, a swap file is a distant memory - A THING OF THE PAST : )
Here is a link to the blog article. In the article I show the steps i took to get each driver going.
http://www.vitalbodies.com/blog/2010/03/09/getting-a-3dconnexion-device-running-in-ubuntu/

I got as far on each version of the driver (open source and proprietary) as getting them working in Ubuntu but not Blender.
I figured the open source version might work better in that it is setup for open source applications and operating systems.
I am willing to use what ever works though.


(VitalBodies) #12

That is the problem. I needed a recompiled 64-bit plug file. I just did not know how to recompile the plug file.