Getting blocky raytraced shadows

Problem Solved


That looks like a mesh, not a shadow problem.

Try pressing ctrl-n to recalculate normals. If that does not fix it, or the problem gets worse then you may have multiple faces in the same location.
I recently posted a remedy to the second case here.

No, forTe, unfortunately that is not the problem. I’m quite sure of it. I tried the things in the other thread, but they didn’t work. I’m 95% sure it’s a raytraced shadow problem because of the animation I did. The blocky shadows appeared all over the head as it rotated in my animation. As the head turned, the blocky shadows disappeared from under the nose and on the eyebrows and appeared in other places. In fact, if you look at the picture above, you can see some blocky shadows on the left side of the face.

If you turn on bias in the material buttons it should fix it. I had blocky shadows before on round objects and it fixed them.

I know. I tried using bias. That worked to some degree, but not well enough. Turning on bias made the blocky shadows slightly less dark, but it didn’t fix the problem of the shadows being blocky and not smooth. In other words, the problem is still there, but it’s slightly improved. I still need a better solution if possible.

Here’s a shot after turning on bias:

Remove doubles, set smooth, and subsurf.