Getting Proper Transparency with Indigo

I’m having a bit of trouble with transparency (like glass) and Indigo, see

If you have suggestions, can you either reply here or in the blog post?

By the way, lowering the alpha of the material, which is what I need to do in Blender to get it to work correctly, appears not to work in Indigo. I tried it, but I couldn’t get it to a nice level before I posted the blog post.

Thanks!

djotaku,

In order to get transparency, you will have to lower the gain for the material in the blendigo gui. In the attached image - still a wip, the hanging lamps have glass material that is setup in Blendigo as follows:

Ingigo mat SPECULARR = transparent + sss
Spec type: specular Transparent clicked on IOR: 1.5
Medium Type: basic Cauchy B coeff 0.000
Precedence no 10
Gain 10.0
Subsurface scattering off

If you haven’t already, create an account at Indigo. They have helped me out quite a bit in the short time I have been working with Indigo.

Attachments


thanks a bunch with that - I’m going to try it out and let you know if it worked

Your suggestion doesn’t appear to be working. However, I did put the alpha back up to 1. Was I supposed to have the Gain to 10 and the Alpha also a low number?

See attached files for the result - which appears to be the same as before and the blendigo/blender settings

Attachments



I basically worked through the same problem a couple of weeks ago. See this thread where several indigo users helped me out. I also figured out some Blender settings that were indicated incorrectly in the tutorial - esp the second last post.

http://www.indigorenderer.com/joomla/forum/viewtopic.php?t=2994

l3la, I see where yours is helpful for shininess, but not for glassiness

OBI - I think I see where I may have messed up - transparency was no longer depressed when I lowered the gain as you suggested. Am trying it again.

However, just so I know, do I also need to decrease the alpha? Thanks!

I’m only 4 minutes in and I can tell it’s going to work now, thanks!

I’m going to leave it overnight and maybe even while I’m at work and then post a link to the result.

djotaku,

I am relatively new to Indigo, but from what I can gather, there are 2 other things you will need to consider in the long run:

  1. Scale settings in the Blendigo gui
  2. The thickness of the object

In Blender, we have a simple slider for alpha. It is kind of like gain in Indigo, as long as you take into consideration scale and object size.

Best of Luck!

Here’s the final result - thanks a lot for all your help

i had exactly the same probleme,
but may be
this will help
http://www.indigorenderer.com/joomla/forum/viewtopic.php?t=2987
If somebody can explain what is gain,
It will be really nice…