Getting rid of a pause in a cycle

This is a recent test render of a walkcycle I made for a character I would like to animate. This is the first character I’ve really started to animate, and the noticeable pause where the cycle repeats is painfully obvious. I would like to get rid of it so it flows smoothly. I thought that maybe going into the IPO curves and manually setting them so they went smoother might have to be done, but I was wondering if anyone else had a less stressful way of doing it. Any help is appreciated.

I’d bet that the ‘pause’ is because the first and last frame are the same - hence you have it twice in a row, once at the beginning, and once at the end of the cycle.

So insert a key at the second to last frame, delete the last frame, and see if that fixes it.


Thanks for the suggestion. Got it all fixed up now. Thank you again!