Ghibli grass with geometry nodes

Im trying to make ghibli grass using https://www.youtube.com/watch?v=6hyztL8btlY but with geometry nodes. Im trying to do it with geometry nodes for more control. The problem i have is that when i apply the texture the grass blades from geometry nodes dont take the colour.


Top is with geometry node and the bottom with with hair system.
Any way i can fix this would be great.
Thanks.

having the same issue brother let me know if u found the solution and why is no one replied to this yet

I runned into the same issue, but found a way to fix this. Just for anybody that finds this topic later on:

You need to create a Color Attribute and use that as input for your diffuse color.

On the ground mesh change the diffuse/prinicipal BDSF to an emiter shader, if it isn’t one. This just makes baking the Color Attribute easier. Under Object data Properties add a new Color Attribute. Go into render settings, make sure its on Cycles, and Bake the Emision with the output changed from Image Texture to Color Attribute. This should bake the current coloring as a Color Attribute. You can check if it succeeded, by going into Solid shade view and changing the shading to Attribute. You might need to subdivide your plane a couple times before the bake.

Then in your Geo nodes at the end of the instances (before the Join geometry node), add a realize Instance node (it doesn’t work otherwise unfortunately), and add a Capture Attribute node after that. Change it from float to color. Put the input value in your Group input, and the output Value in your Group output.

In the Geo modifier you change the input value to the Color Attribute you created in step 1. And the output value to anything you want.

In the grass shader you add an Attribute node. Put the output name value in the Name part. Connect the color output to the rest of your shader, and if everything went alright it should now have the same color as the ground.