GIMP 2.8.10 released

Overview of Changes from GIMP 2.8.8 to GIMP 2.8.10

Core:

  • Set manifest as Windows 8 compatible

GUI:

  • Indicate if a file was exported in the Quit dialog
  • Add shortcuts and hint labels to the close and quit dialogs
    that make closing and quitting easier and more consistent
  • Rename the File->Export menu labels to match Save/Save as
  • Fix keyboard shortcuts on OSX Mavericks
  • Don’t open lots of progress popups when opening many files
  • Correctly restore the hidden state of docks in single window mode

Libgimp:

  • Fix exporting an image consisting of a single layer group
  • Don’t attempt to pick transparent colors

Plug-ins:

  • Fix crash in LCMS plugin if RGB profile was missing

General:

  • Fix compile on NetBSD (missing -lexecinfo)
  • Bug fixes
  • Translation updates

Overview of Changes from GIMP 2.8.6 to GIMP 2.8.8

Core:

  • Make sure indexed images always have a colormap
  • Fix language selection via preferences on Windows
  • Don’t crash on setting a large text size

GUI:

  • Keep the same image active when switching between MWM and SWM
  • Make sure all dockables are properly resizable (particularly shrinkable)
  • Add links to jump directly to Save/Export from the Export/Save
    file extension warning dialogs

Libgimp:

  • Fix GimpPickButton on OSX

Plug-ins:

  • Properly document plug-in-autocrop-layer’s PDB interface
  • Fix importing of indexed BMPs

General:

  • Fix lots of places to use GIO to get proper file sizes and times on windows
  • Add an AppData file for GIMP
  • Backport lcms2 support from master, because lcms1 is not getting
    bug fixes any longer
  • Lots of bug fixes
  • Lots of translation updates

(window build available too on their ftp)


or their server
http://ftp.gimp.org/pub/gimp/v2.8/windows/

There was a problem with the previous release on window ( 2.8.6 ) that had all the plugin being rescanned as if it was the 1st launch every single time you launched Gimp , adding a lots of time to the loading wait.
It was fixed quickly after and so if you used builds from Partha by example, it wasn’t a problem anymore.

But if you use the “official” release only, 2.8.8 should then have this 2.8.6 problem fixed.

Thanks for the information. For Ubuntu and family either of these two PPA:

https://launchpad.net/~otto-kesselgulasch/+archive/gimp

https://launchpad.net/~noobslab/+archive/ppa-gimp

I noticed this video about a gsoc work for gimp :

Did they ever fix the issue where pen pressure was not supported?

Can you give more detail about this issue? Do you know any bug report about it? What operating system you use? What brand and model is your tablet?

Sorry so many questions, is that my generic tablet works perfectly. And as far as I know, the wacom tablets also works well.

I have a Wacom Intuos 4. When 2.8 was initially released there was a known issue that the version of GTK+ they were using did not correctly support pressure pens. They were waiting for a different version of GTK to resolve the issue.

You can download and try GIMP 2.8.8.
If pressure does not work, you try setting your tablet from “Edit” > “Input Devices”. Choose your tablet and in “Mode” choose “Screen”. Save and Close.

About the GTK and the “they’re waiting for the next” , in Gimp 2.7 up to Gimp 2.8.4 there was a bug that made noticable tearing in the image display (on window system) when you were moving your image or scaling it, very annoying one as with larger image it was made worse and introduced some lag to let the tearing disappear.
At the time it was said to be a bug in the current GTK for window versions and so would not be fixed before Gimp 2.10 released sometime in the next decade.
Fortunately they found the issue and fixed it without having to wait that much as starting with Gimp 2.8.6 (and so 2.8.8) this image tearing problem/lag does not exist anymore.

So if you read a year ago that they’re waiting for a GTK upgrade in the next 10 years for a bug to be fixed, don’t give up hope and still try current release, chances are that it’s been fixed.

After I upgrade my iMac 10.8.5 to Maverick 10.9 Gimp don’t work for me.
I try to upgrade to Gimp 2.8.8 but there is no Gimp 2.8.8 for mac users.
Do you know where to look.
Thanks.

Nice update, GUI feels more consistent now.

pressure sensitivity still doesn’t work on windows or linux with Monoprice TWHA60(UC-Logic),
pressure sensitivity works fine with Gimp 2.6, speedy painter, photoshop, sculptris, blender, meshmixer

this one

http://www.monoprice.com/Product?c_id=108&cp_id=10841&cs_id=1084102&p_id=6814&seq=1&format=2

holyenigma74, have you configure input devices like YAFU told?

Yay another release! Congrats!
Since Photoshop’s code is in the wild, GIMP should peek on some code there. XD

I download my drivers from here and my tablet now works with krita and gimp in windows. http://www.uc-logic.com/en/index.php?ParentMenuID=4

yes, when i do that the pointer doesnt even work, when the stylus touches the tablet it
“drags” the canvas… like pressing left mouse+spacebar in photoshop…

thats where i got my drivers from… hmmm
is yours just “working” or does it also have pressure sensitivity.

mine “works” but no sensitivity

If you launch GIMP using mouse, and then get tablet and start painting, pressure won’t work. Simply launch GIMP using tablet and pressure will be working. I have been using GIMP and Wacom Graphire 3 and that was the simple workaround I’ve used since whenever that mess happened.

Ya got to stick with Wacom, alternatives are not really caught up or supported on a driver front and most of the alternatives are cheap taiwanese knock offs. You really do get what you pay for these days, additionally wacom has patented certain tech which gives them the advantage. Not sure when that patent expires.

just tried it clicked the gimp icon with the tablet, no good(no sensitivity)…
then tried setting it to screen… still no good.

gimp 2.8 is the only thing that doesn’t work correctly with this tablet

try going into edit> preferences>input devices. click reset to default then reload GIMP. now go to edit>input devices. and set the pen and eraser to screen press save and you should be up and running again with full sensitivity.