Gimp help! 32 bit tgas


(slikdigit) #1

I feel totally stupid, but after trying for over an hour I can’t get gimp to save transparency information in a tga file. If anyone cares to enlighten this benighted user I’d much appreciate it.
Yours in frustration
Bassam :frowning:


(SatoriGFX) #2

It would help if you tell us the exact steps you are taking. We need more detail.

SatoriGFX.


(wavk) #3

Hi, Bassam,

I couldn’t resist investigating this problem, for I have encountered it several times myself, too. I tried several things, like adding a new channel with the name Alpha, which wouldn’t work. I guess you have a couple of layers with layer masks?

The solution is to add a new layer which has the Layer Fill Type set to Transparent. This layer should be on the bottom of the stack. This is irritating because this layer cannot be brought to the bottom, the bottom layer won’t switch places. The solution to this is to duplicate the bottom layer, move the Transparent layer beneath the copy and deleting the bottom layer:)

When you export your image now to tga or png, the alpha is saved!

SatoriGFX is right, your question wasn’t completely clear, probably because you were frustrated after an hour of trying :wink:

WAVK


(SatoriGFX) #4

wavk,

Actually the bottom layer CAN be moved up and can also be made to contain alpha information. The solution? Right click on the layer and select “Add Alpha Channel”.

This is necessary only if the original background layer does not contain an alpha channel when loaded.

SatoriGFX.


(wavk) #5

Yo SatoriGFX,

You’re so right:) Can’t see how it didn’t work before. Thanks for the info, now I know what “add alpha channel” does! I thought it would add an alpha channel, like the name implies, so I go check in the channels tab, but no. Now I see that it enables the creation of a layer mask. I guess you’ll have to add the alpha channel to the bottom layer manually, because otherwise all images would contain an alpha channel, no?

WAVK


(slikdigit) #6

well, here’s what I tried:
1- just adding a channel with parts masked out. that didn’t work- and the channel was gone after saving- reopenening
2-creating a one layer image, and erasing parts of the layer to transparent. hit flatten image, then add alpha, then saved. when it was reopened the transpareant parts had been filled in with black or white, no alpha. Blender didn’t see an alpha channel there either.
3- In one of the web tuturials I saw in the save tga options a 24 bit vs. 32 bit option in the tga save dialogue. I don’t get that option. I upgraded from 1.21 to 1.23 but no dice. Is there a tga transparancy library I should download.
4- how do you ‘see’ the alpha channel in gimp? alpha to selection always selects the entire image- presumably 'cuz I don’t have an alpha channel.
Any thoughts? I’ll try your steps. The reason I didn’t give much information is becuase I tried so much that did’nt work that I didn’t even remember what I had done.
ps- I also tried saving as xcf first. in the step 2 version I got 3 channels (RGB) that all had the trasparencey. I resaved as .tga and I got the same result as 2.
ps- sometimes I wouldnt even get rgb channels- because my image was black and white, I would get a greyscale image.


(wavk) #7

Hi, bassaminator,

Answer to number 3: no, there’s no 24 bit vs. 32 bit option in the tga save dialogue here also, the Gimp decides on this automatically I guess.

Good luck with trying:)

WAVK


(slikdigit) #8

I guess I needed a 'follow the bouncing ball, ya moron!" type of answer, and you gave me the steps required. Funny thing is I was doing those steps but maybe not in the right order. Also an oddity: I can’t do “add alpha channel” until I flatten image first. What gives? This happens even if the image is a one layer image, and even if I flatten it , then do something else, then try to add an alpha channel again.
no matter, since the tga’s are flattened anyway and the xcf’s save everything. Just a curiousity in this case.
SatoriGFX+Wavk = Rulz


(SatoriGFX) #9

http://gimp-savvy.com/BOOK/index.html?node13.html

Should tell you everything you ever wanted to know about Gimp.

SatoriGFX.


(DAK) #10

I know one problem with gimp. You can get alpha to work with color only. You hit calc alpha in texture menu to see the alpha. But as soon as you hit NOR, it will bump the original image and ignore the alpha. I do not know yet of a quick way to fix this.