gimp problem

I was trying to get my tablet to work with gimp without ignoring wintab(that defeats the purpose of using a tablet). So I was looking through the gimp bug reports and found this thread.

In it there is a patch to fix the problem. This is really stuped, but how do I apply it? If its not actually a patch, call me dumb or something, but don’t ignore the post. Thanks for your help.


as far as I know, wacom tablets have never worked right with the gimp in windows

/me tries

(gimp-2.0.exe:2792): Gdk-WARNING **: losing last reference to undestroyed window

(gimp-2.0.exe:2792): GLib-GObject-CRITICAL **: file gobject.c: line 1320 (g_obje
ct_ref): assertion `object->ref_count > 0' failed

(gimp-2.0.exe:2792): GLib-GObject-CRITICAL **: file gobject.c: line 1338 (g_obje
ct_unref): assertion `object->ref_count > 0' failed

(gimp-2.0.exe:2792): GLib-GObject-CRITICAL **: file gobject.c: line 1338 (g_obje
ct_unref): assertion `object->ref_count > 0' failed

okay, so it doesn’t fail the same way as 1.2 did (which I got to work like twice).

I’m also interested.

I’ve just recieved a new Wacom (Graphire III) and I’m getting problems with the GIMP (Windows). It seems the patch works (from the responses there) but the link to the patch seems to be broken. Do you know if this patch works for the GIMP 2.0?

Can anyone help?


Yes, I should have said windows. I did say it was a problem with wintab though.

It says its a patch for windows gtk, not gimp. The problem lies in gtks interaction with wintab. And apparently it works with gtk 2.4 and 2.2 so that means it will work with gimp 2. I just want to find and apply the patch now.

Since we’re on topic here, anyone know how to merge a different image over another, with transparents ?

I think you just do ctrl C on the image you want to copy to a layer, then select the target image, add a new layer i think, then ctrl V to paste the 1st image, and in layers menu select ‘anchor layer’. I think that’s the way though I might be wrong. You can adjust the transparency of either layer by selecting them and using the opacity slider.

Where’s the opacity slider at ?

on the layer dialog, at the top

as for pasting as a new layer, if you paste you end up with a floating layer
then right-click on it, and choose new layer

ok, got it, works great, thanks

Ok to get back to my initial gimp problem with the tablets, I’ve been following progress…

have a look at this post

So now gtk 2.4.3 is out and here he’s got the win32 files, but no installer yet.

Ok and here’s an installer that supposedly has the tablet support enabled.

Now I should be able to install this and then use “–use-wintab” in the shortcut and my tablet should work… Nope, oh well, but mines not a wacom(I think the patch was written by a wacom owner) so I’d like to hear if anybody can get there tablets working with gimp on windows like it now should officially do.