Glare Node Blowing out firefly artifacts?

I’m rendering this scene in Eevee and the glare node is doing something weird. In the viewport I see some fireflies in the area the white block is coming from but I don’t know how to fix it.

Here’s the node setup:


I turned off the comp glare and used the eevee checkbox bloom. It’s not giving the giant artifact now but I see the white marks on the bottom that are probably the culprit. Anyone know what this is?



Turns out it was an edge I didn’t realize was there when I was making the ground plane. I guess there was a sharp spec hit on the edge or something. I deleted the straggling edge and problem solved!