Glass casting shadows?

In Yafray the standard clear glass material completely blocks light from getting through, even though it appears to be clear. So I can see the object through it, but the object is unlit if the light is on the near side of the glass.

What am I doing wrong?

Try using the caustics with the “full” GI rendering. Im sorry, this is one thing i dont know much about. I think this is the problem though, serch cuastics on blender3d.org… hope this helps

this is real issue for yafray. There are two workarounds though:

http://wiki.yafray.org/bin/view.pl/UserDoc/FaqEng?CGISESSID=18a640d0cfedd7bc5b03bf6319e751e8#Q37_I_can_get_YafRay_Lights_to_l

ALvaro.

Ok, I was able to get the photon lamp to work, but that’s definately going to need a lot of tweaking… How do you get into the XML?

You don’t need to edit the XML file. If you keep on reading, it says

…or if you use Blender, disable the ‘traceable’ button in the ‘Links and Pipeline’ panel of the material section.

About the photonlamp solution, try interior7.blend, located inside this zip file:
http://www.zshare.net/download/yaf-proves-zip.html

Alvaro.

Sorry, missed that >.<

Thanks muchly for the help.

Just stumbled over the same problem…

Can I let the shadow be weak behind the glass or does it need to be completely disabled by the method described above: “disable the ‘traceable’ button in the ‘Links and Pipeline’ panel of the material section”?