Glass material material behaves differently in viewport and render

Heya!

I have some issues with a glass material i use for my bathrooms windows.

I recently ran into a similar issues when working on another interior project, but luckily it was solved by a few members here at BA.

Now this time my glass material i use, only works when doing a viewport render. All displacements, nodes and so on works perfectly fine when doing so. But when i do a full render, none of it seems to work. I can only guess that it has something to do with camera rays, or environment lightning but i honestly have no clue :yes:.

Here are some images displaying my issues

(very poor sample size!)


There’s probably a very simple solution to this, but if not i respect every little help i can get!

Cheers.

Please always supply a .blend file with every support question. How on earth are we supposed to know what’s going on in your scene otherwise?

BTW, just to eliminate the obvious:
Is the window mesh perhaps set to be visible in the viewport (eye icon), but non-renderable (camera icon) in the outliner? Looks like that window is not even there at all in the F12 render…

I was so far up my ass fixing the glass issue i forgot both to include the blend file and turn the render icon on…

Oh well, there goes my career.

By the way, thank you for reminding me and fixing my issue. (embarrassed) :yes:

Yeah, sometimes we don’t see the wood for the trees…:smiley:
Good to hear that this is solved!