Glassware problem

Hey Guys, Perhaps some material gurus can offer some advice on a problem I am having.

-First off take a look at the light path settings that I am using. These are the standard ones I use for an interior arch viz project I am working on. Normally however I have both reflective and refractive caustics unchecked. But because of using the glassware, I did enable it in this screen grab render

-This is only 500 samples … normally I render 3000 samples, so don’t be concerned about the noise

-The glassware in this render is just a single face…there is no “inside of the glass” so all the normals are facing outward. I’ve made sure to recalculate normal and apply scale.

-As you can see I am getting some black uglyness when the glasses are at a certain angle toward the camera. There are 2 glasses at each place setting, the blackness seems to occur when 1 glass is directly in front of the other in the camera view.

My question are

  1. what would be the minimum amount of transparancy bounces I should try to correct the problem. (that’s assuming the problem is caused by too low of samples) ?

  2. Based on the glassware only having an outside profile, am I really benefing by having the caustic checkboxes enabled?

3)EDIT Is there something other than transparacy bounces that is causing the problem? I just tested quickly 64 and it didnt seem to change… at least in my 100 sample qucik test.


So, that’s a refractive shader (glass / refraction) on single faced objects? Don’t. Just… don’t.
Never use refractive shaders on objects that are physically implausible. For Cycles the upper part of these glasses is a massive solid piece of glass now, as it calculates from face normal to face normal…

@ Ikari But what do you think is causing the dark ugly areas? … The only reason I have single face is I thought the thickness that I made the glass was too much and causing problems. I have no issue disabling all caustics.

are you using glass ore refraction node ?
you can remove caustic wont change much if your sample is less then 1000

but for refraction you need thickness
and if you have more then one glass in sequence it means you might have to increase number of light path panel
values for number of glass layers

happy cl

As for the blackness: I rather think the transmission bounces are to blame and not the transparency bounces. And you will also have to increase the total max bounces.

Examp here

Branch path tracing
lightpath transparency
= 8 means 4 layersof glass max-bouncess with lot’s of plate increase values
this will removeblackbox in glass

happy cl

Think the problem is fixed… what really solved it was the transmission bounces… I bumped it up to 32 and raised bounces to 8.

I’ll have to see if these changes affect anything in the entire scene (increased noise, fireflies…ect) but at least it has solved the glass problem

Thanks to both Ikari Shinji and Ricky for your help. I learned something today, I would have never thought to mess around with transmission bounces… I hope to get a nice closeup render of the table setting by tomorrow… but first I need to model some silverware. Check in at the “Relapse” WIP thread in my signature, if your interested in seeing how it comes out.

@ricky I ended up disabling both type of caustics

From my understanding the max bounces are a kind of “absolute ceiling” for all bounce types…
So, even if your transmission bounces are set to 32, they will be capped at the 8 total bounces. Might be wrong, though.

sadly caustic in cycles is almost useless
hope to get something new for this effect one day before 2020!LOL

happy cl