Global illumination help?

I tried the Global illumination tutorial at blender.org. but my spot light never comes out the way it is in the tutorial. The lights are outside the dome. If I try lowering the first lamp it still doesn’t work? This may have a simple solution, since I’m not very knowledgable with Blender yet.

http://i84.photobucket.com/albums/k31/Julius_Sneezer/duplivert.jpg

Thanks for the assistance if available.

I suspect your normals are pointing outward.
try to recalculate inside with Ctrl+Shift+N.

Shift + C and then Shift+S->Selection to Cursor with the Spot should help normally. If that doesn’t help, You could perhaps try things like Alt + R or Ctrl+A wih both objects.

@ tixy: I think then the Spots would go outside the Mesh, not to the center.

Ok I tried them and it came out with exactly the same results. I’m going to experiment with different spheres and things and see if there is a difference.

I found a work around as I usually have to do with Blender since its always full of bugs.
Does anything work in Blender? Seriously, I’m definitely fed up with up the bugs and poor logistical design. Why does it take 10 to 15 steps to do something that only takes 2 steps in Gmax? Because Gmax is professionally written. I’ll have to save my money buy a professional program and leave Blender, just to do some modelling.

Anyways now that I’ve blown off some steam.
I created the dome and the spot light and dupliverted it but a little smaller than the final result. Then I made all of the spot lights REAL. Then I alt - p to seperate the parent. Then scaled up the dome to its proper size. So many steps extra, as usual.

Also electing the lamp, the editing parameters never show up. I found a work around for that as well. I have to add two lamps to be able to edit one. Then I delete the second lamp. Simple right? I could spend all day and the next day and the next pointing out bugs in Blender 2.47, but hey the only reason I use it because I can’t afford anything else…until now. Hexagon 2.5 is on sale for $37.00 until October 30 if you buy the September issue of 3D World and install the disc that comes with it.

Ranting about “bugs” is not going to help you. If they truly are bugs (and not a disillusion of actual functionality), then you should report them, so that the nice developers can fix them. Personally, I have only ever found 3 bugs in Blender, and I quickly got them fixed.

As for your problem, if you want to make a quick skydome do the following:
Space>Add>Mesh>UVSphere
Change Segments, Rings, and Radius as needed.
Tab, B, select bottom of sphere, X>Vertices
Tab, Space>Add>Lamp>Spot
Shift RMB Sphere, Control P
F7, Dupliverts, Rot
RMB Sphere, Tab, Control Shift N

…and there you go, a 30 sec process. It may interest you to learn about AO (ambient occlusion), and AAO, which are a lot easier to set up.
http://wiki.blender.org/index.php/Manual/Ambient_Occlusion
To use AAO, just change Raytrace to Approximate; AAO is a lot faster than traditional AO.

And also, as I have seen, the docs at blender.org are severely outdated, a better source of information is the Blender Wiki:
http://wiki.blender.org/index.php/Main_Page

I tried a UVsphere your recommended as well and got the same results. How come everyone else’s works but mine does not? Was my 2.47 download corrupted somehow? How could Blender run if it was corrupted though. I heard someone say the Linux version of Blender is alot more stable. Maybe thats it. I’m using Win xp.

As for ranting, like I said before, I’m not going spend months submitting bug reports.

Did you move the sphere or the spot before you dupliverted it? That is usually the cause of this complaint.

Devs can’t fix bugs they don’t know about. If you are finding a lot of bugs, then chances are the problem exists between keyboard and chair.

Software can be frustrating to use if you do not follow the steps correctly. Slow down, read it carefully, and read it again before following it exactly - “if you offroad, you don’t know where you will end up, but it won’t be where the roadmap says you should be.”

Hey,

I believe that your problem is really the loss of patience…
Go over the tutorial once again, step by step and after that if you are still sure that you have a corrupted version of blender, just download it again.

Fort Ash

Make sure you don’t translate any of the objects, as this might offset the them from their origins.

Blender is the same on Windows as it is on Linux, BSD, or Unix (that’s one of its features, no matter what OS you’re using, it is the same). What people refer to is that Linux handles Blender nicely, not that Blender for Linux is intrinsically better. If you have a good machine and know your way about windows (i.e. a power user), windows is perfectly fine for Blender and most other work.

Thanks guys and gals. Sorry for getting steamed up. To say I’m frustrated with Blender is an understatement. I’ve been trying to learn Blender probably longer than anybody with the least learned. Me and Blender just don’t see eye to eye. It took me 6 months to do something that only took me 3 hours with the trial version of 3dmax. So ya, I don’t find Blender intuitive to me anyway.

As for making a mistake in the tutorial. Maybe I did. I’m certainly not perfect. My brain is not what it once was for certain reasons. But I don’t give up entirely on something.

Like I said my work around method of making the lights REAL atleast works so I’m not going to mess that for now.

Now I have a new problem. I’ve tried every setting in Blender that I can think of to no avail.
I created normal maps for all of rivets on my bridge. But for some reason the render is not turning out correctly, there is streaks and sometimes no maps showing up.

At first I thought the spot lights were overlapping. So I removed every spot light and put in one single area light over a trouble spot. Guess what? Same problem. I’ve played with the normal size, offsets etc but still nothing. So if somebody can put up with me and my ranting and raving, I would appreciate some assistance on this one.

http://i84.photobucket.com/albums/k31/Julius_Sneezer/render3.jpg

man if love gmax and 3dmax so much why dont you marry them ? the tutorial explains itself very clear , if are a noob and dont know how to read , its not blenders fault , anyway if dont even know how to use blender , its very improbable that you find bugs.

Go waste your money on 3dmax , you’ll be back to blender in a couple of years when you realise blender is way much better

in any case here it is :

just apppned or link it its in a group called PGI: http://www.mediafire.com/download.php?lztnzjddmny

Hi Julius, I know what you mean, it can be very very frustrating fighting against an application and not to obtain the results you hope from. Me too I had to fight and fight again against the interface, the shortcuts the “blender way of thinking”… let me say :slight_smile:

But I assure you simly one thing, when you’ll be successfull with all of those headaches, you’ll have a lot of satisfaction and everything even most complicated will appear to you as joke, as fun.

My only advice, out of this particular scene or situation is to consider yourself completely unknowing in blender. Try and pretend to forget everything you know about global illumination eg. and start to read the wiki chapter like it was the first time you do that. Every every line, every word, try and understand it in the essence and every line try to reproduce in your blender copy. If you’ll do that way you’ll obtain for sure your goal plus you’ll discover you’re very fast and blender is a powerful tool to use. Trust me, way better than a lot of software out there.

Good luck man!

Please keep in mind that the developers spend their months/years of free time to make Blender, and then they give it away for free and also invite everybody to participate.

Just to put it into perspective…

Edit: Oh, and I forgot the documenters who also spend a lot of time to provide us with documentation in order to keep frustration levels at a minimum. :slight_smile:

Ok, lets tackle these one at a time.

The slightly elevated spot issue really isn’t an issue at all. it won’t do much to affect the lighting as the actual sphere is invisible once the ‘dupliverts’ option is activated. But if it really concerns you, the spotlight needs to be in exactly the same location as the centre point of the sphere for this to work.

In fact, now that I look at your screenshot again, I can see that your centre point is in the wrong location, meaning that you’ve probably moved the vertices into position in editmode. If you had just created a sphere, gone into editmode, then deleted the bottom half of the sphere, the centre point would be aligned to the bottom loop of vertices. It wouldn’t be in the centre like your screenshot shows.

Try this for an experiment. In object mode, move the sphere around. You’ll notice that the centre point moves with the sphere. Now go into editmode, select all the verts, then move them. You will notice that the centre point stays in the same location regardless of how you translate the mesh. This is a very important distinction in Blender, as the objects centre point is used for a hell of a lot more than just rotation. Dupliverts, textures, and a lot of the modifiers use them as well.

These ‘bugs’ are simply your lack of understanding of the program and how it works.

Also, the dupliverted spotlight trick is a very out of date lighting rig that was popular about seven years ago. There really is no need to use it at all. You should be using Approximate ambient Occlusion, which will provide cleaner and more even light, better shadows, and will do it a lot quicker.

it took me 6 months to do something that only took me 3 hours with the trial version of 3dmax.
Ok, that is bordering on the ridiculous. The only way this is true is if you tried it once, didn’t use blender for 5 months and 29 days, then decided to do a little research on the matter. It took me 3 months to get proficient with Blender, and that was with version 1.8. At the time there was almost zero documentation and the interface was much harder to understand.

As for the textures, they are mapped incorrectly. For us to help you with this, a screenshot isn’t going to cut it. Are the textures uvmapped? If not, what mapping type are you using? A .blend file would be the best option here, as we can take a look at what you are attempting to do.

I would bet the bizarre girder triangles are a result of a poor model (no offense). Try selecting and removing doubles.

One point I missed:

I found a work around as I usually have to do with Blender since its always full of bugs.
Does anything work in Blender? Seriously, I’m definitely fed up with up the bugs and poor logistical design. Why does it take 10 to 15 steps to do something that only takes 2 steps in Gmax? Because Gmax is professionally written. I’ll have to save my money buy a professional program and leave Blender, just to do some modelling.
If you can’t model with blender, then you probably can’t model with anything. You should probably watch some modeling sessions from someone who has actually taken the time to learn the program, before making rash judgments.

Like this one for instance:

http://www.vimeo.com/1088413

Notice how he manages to do almost everything without leaving the main 3d view? That is not exactly what I’d call poor logistical design. But meh, have fun with Gmax.

Hey,

Hi Julius, I know what you mean, it can be very very frustrating fighting against an application and not to obtain the results you hope from. Me too I had to fight and fight again against the interface, the shortcuts the “blender way of thinking”… let me say

I also have this problem sometimes but the key is not to get to worked up about it…
If I get to a problem when something goes horribly wrong I load a previous blend file…
Thats probably why I have my computer full of useless .blends:no:.
The shortcuts are actually not necessary to be used. And you get used to them after a while…

I’ve been working with Blender for 2-3 years now and I learned that blender isn’t too much different than other 3D software. Maybe more complicated… For some people. Through years you learn a way or two to make something, and then you just combine this ways to create something great… Knowledge means power.

Fort Ash

Actually it is good for two things: if you tilt the sphere you’ll get a directional shadowing effect or if you desire a certain type of lamp for the effect (they all provide truly different results) but I’ve only had to use those on one occasion.

Cinnamon gravy! Boy some of you defend Blender like a long lost lover or something, Sorry I’m not that sentimental. As taking longer to model something in Blender than other packages No I’m not lying so don’t say that. As for Blender’s ease of use with no documentation needed. Ya right, I have some swamp land in Florida you might be interested in purchasing. Pickles and peppers!

I’ll try the GI tutorial again. I don’t believe I moved anything around during the process, but I’ll do it again.

As for my new problem of my normal map not looking correct. I figured it out after much meditation on it.

One of my problems is my memory is not too good as it used to be. I learn something about Blender then within a week I completely forget everything that I learned. Maybe its better that I don’t post anymore I seem to offend everybody instead of looking for help.