Global illumination in Eevee vs Cycles

I’m very close to what I want but not quite there…

Here’s a test setup of my interior with a single glowing light using an emissive texture - rendered in Eevee with an “Irradiance Volume” around the room. Notice the walls flush with the light are actually darker than the wall further away.

If I switch to Cycles (default settings) I get this lovely render in the viewport - THIS looks realistic. (Side note - I had to move inside the room, since backface culling doesn’t seem to be working, even though it’s enabled in the cycles renderer- not sure why that is!)

image

But if I render using Cycles, I actually get NO global illumination!

image

So I have 2 questions;

  1. Are there any tweaks I can make using Eevee to make it fill out the light on the closer walls more realistically?
  2. Why doesn’t the Cycles render look as good as the viewport?

Here’s my Blender file:
Global illumination.blend.tar.gz (175.0 KB)

Cycles doesn’t support, or rather, adhere, to the backface culling. You can do a shader hack though, using a mix shader:
Slot 1 - Your main material.
Slot 2 - Transparent shader.
Fac - Multiply light path/camera ray with geometry/backfacing.

Hard to guess what is wrong with your Cycles render settings without actually seeing the file.
As for Eevee, I’m not very confident there. I’ve had no problems baking indirect light and having it look great. Horrific shadows and bleeding are what scares me away from Eevee though, time and time again.

2 Likes

Ah thanks for the backfacing tip for Cycles. So weird that there’s a checkbox for it in it’s shader menu when it doesn’t support it though!

Oh, my blender scene, good idea - I just updated my original post with the scene attached.
Actually I had some strange bleeding in Eevee until I added the Irradiance Volume. But if you can work out what’s wrong with the Cycles render, I’ll happily work in Eevee and then maybe do a final render with Cycles… and see how that goes. (I know they differ in many ways, but I’ll just be sticking to emissive materials in this room, no other lights, so hopefully that simplifies things.)

No issues here. Camera was not positioned to be inside the room, maybe you rendered the outside? Didn’t check. Eevee looks good too, although I increased the emission intensity.

The Cycles render is done from the same location as the Cycles viewport screenshot above - from inside the room. If I rendered the outside, there would be no light at all. As for why it looks more skewed, I don’t know. I moved the camera inside, took the viewport screenshot, then immediately did a render as well. It’s the same location.

I don’t want Eevee to have the emission intensity bumped up. As you can see from the screenshot, the far wall is lit more than the close wall. If it was like that for you before you bumped up the intensity, that won’t work for me. I daresay after you bumped it up, the far wall was still brighter than the closer walls until they reached maximum brightness.

When you hit F12 to render, it renders the active camera. Your active camera is placed outside. Go to wireframe view and hit 7 to go to top view to verify.

If you want to update your active camera to current view, adjust your view and hit ctrl+alt+0 (numpad).

If you delete your camera from the scene and hit F12, you’ll get the error message “No camera found in scene”.

Ahh thank you, that clears things up. Yes I was rendering the camera and that was the outside view :frowning: and the reason I could see the light is because the camera is facing from behind, and the light is clipping through a bit! That was confusing because it looked kind of similar to the viewport…

Maybe there will be a way to tweak Eevee to render the light a bit better, but now that I can see a decent result in Eevee and do a final render in Cycles, I’ve got what I want. Thanks CarlG :slight_smile:

This is my cycles render;
image