Glossy UV texturing?

Good morning every one.

I am having some problems with UV mapping. i have modeled a coke can and used uv mapping to give it the Coke logos and so on, but i have only done this on the side of the can, the top and bottom are i have left so that i can use the standard material controls to give it a metal like finish and a nice gloss (reflection). but as soon as i enable the TexFace button i can no longer adjust the Standard Material settings and all i am left with is a soft gray colour for the top of my can. also the for the reflection and “gloss” look just does not seem to function as well as normal.

These are the control settings

and here is the can

You will notice that the material colour is red but the cop of the can is still gray.
and the RayMir slider is almost full but the can still looks matt

Any help would be of amazing

Hi stew_dog

as far as I can see, you do not need to press the texface button at all. It suffices to press the UV-button in the Map-to panel in order to get your images uv mapped. For that you assign your UV-mapped image to a texture channel and then press the UV button in the Map to panel.
There is an older thread about the texface-button, which might interest you:

http://blenderartists.org/forum/showthread.php?t=135375

cheers,
Sloane