GLSL Clip Alpha Bug?

Hey. It seems like I can’t use Clip Alpha with GLSL mode on - it just seems to make the whole object opaque, even if I set the transparency slider to 0. Now it seems like it never uses the alpha of the texture that I assign to it, and, yes, the texture does have alpha. Does anyone else have this issue? Can anyone else use Clip Alpha with GLSL on?

EDIT: It must be a bug. Man, I wonder why it broke, and only in GLSL mode?

EDIT 2: Submitted to the Blender bug tracker.

No problems with clip alpha in GLSL mode on blender 2.63 r46237.

Wow, really? Great to hear. I’m glad that such problems are spotted and fixed before people like me can even make an out-dated post about them! LOL

EDIT: Are you sure? I just got r46298 from GraphicAll, and it seems to be the same… Are you sure that you’re in GLSL mode?

Definitely GLSL. Works fine both with and without mip-mapping. My OS and hardware are different to yours though I think. My OS is Kubuntu 12.04, my graphics card is Nvidia GTX 560 ti.

Hm… The graphics card and OS shouldn’t matter - it’s very odd that we’re getting different results. I wonder if it’s something wrong with my setup…?

EDIT: Did you tick Z-Transparency? Otherwise, other objects won’t show through the ‘transparent’ object.

Z-Transparency is what I used.

Edit: I did have a weird glitch I duplicated the plane with the alpha material on it, that went fine. But when I undid the duplication the texture went completely transparent with only a few glychy dots showing. Reloading the texture fixed this problem.

Edit: Odd, I can’t seem to repeat the problem.

Really strange. Could you post a screenshot of your material settings / how it looks for you?

Here’s a screenshot. Mapping coordinates are set to UV.

Attachments


Can you do me one final favor and post that blend file? Any texture that has the Clip Alpha working is fine.

Ok, here is the blend file. Hope you are able to get to the bottom of the problem.:slight_smile:

Attachments

Clip-alpha_feather.blend (1.4 MB)

It looks exactly like my own tests - the plane’s black with the image of the feather. There’s no transparency. :frowning:

Man, this is unfortunate.

EDIT: Something I’ve noticed is that face textures seems to be implemented (but broken) in GLSL mode (they weren’t before). If you don’t have a material on a GLSL object, it will default to the UV-image assigned to the mesh, and do so with Alpha (?) enabled. This might be related to the problem.

If I understood what you are meaning I assigned the feather texture to the plane in the UV image editor then deleted the material with nothing unusual happening; the feather image disappeared once the material was deleted. What was the last version(/build) of blender that you were using before this happened?

The test file from CrazedQuetzal is working for me on 2.63 for OS X from the latest build on blender.org, not graphical.

@CrazedQuetzal - I don’t recall - I don’t usually use GLSL mode with Clip Alpha textures, so I don’t remember when it last worked. EDIT: Did you press P to play the game?

@RossBlenderArt - The build from Blender.org didn’t work for me either. I’ll have to check out the settings of my graphics card - it MUST be something I’m missing. EDIT: And you used GLSL mode? Mutlitexture and Singletexture mode work fine for me - it’s just GLSL mode that’s the issue. :I

EDIT: Now this is really disheartening - I went all the way back to 2.49b, and the problem’s still there. It must be something wrong with my graphics card. :frowning:

EDIT 2: Updating the graphics card driver didn’t help. :confused:

Yes, it was GLSL, sorry about your problem, but hey, atleast you can use GLSL! :wink: