GLSL mode in viewport

i did a normal map and applied it to a plane
then set GLSL and i can render it no problem

but to see it in viewport
i ahd some problem to set it up

it’s only after i added the normal image in UV editor that i could see it
but not certain what made it appear?

what is the normal procedure to see the UV image in viewpor with GLSL ?

thanks

As soon as you have baked and saved (to be on the safe side) normalmap, go to editmode, have that baked image and uv in uv editor, in materials click Assign. Then, if all was checked in Textures - Image Sampling-Normal Map, Mapping - UV, Influence: Geometry - Normal, then it appears (don’t forget lights in 3dview).
Guess that’s a bit different than it was before…

Happy blending!

i saw some problems and not certain how i corrected it

i used the cgcookie tut on baking with floating geometry
and i could not see it in the viewport even after uploading it in texture panel
then not certain i added the image in the UV editor and i saw it
but is it the normal procedure i doubt it is like that

when is the image seen in viewport in GLSL mode ?

thanks

RickyBlender , aren’t you using a G31/G33 card from Intel ?

If you’re always using this card, GLSL will not work in the viewport because the clowns at Intel never made the card and its drivers supporting more than OpenGL 1.4 (GLSL needs OpenGL 2.0) and never redirected the OpenGL shader to be CPU managed (they did it , but only for Direct3D shaders).

yes i goat intel G33

but never had problems to see it in viewport using normal GLSL

but here i bake it and was finaly able to see it

it’s only how i got there that i’m not certain !

thanks

Wait a minute, when you have a model with a normal maps material, you can see the normal map in the viewport ?

as i know of yes no problem with GLSL!

what are you having problems with that ?

salutations

Hard for me to understand how you can see those special material when using GLSL, as the G31/G33 card do not support GLSL.

For me enabling GLSL does exactly the same as if i have Multitexture, every GLSL special display are simply ignored in the viewport and it displays no more than what Multitexture would do.

Can you load this .blend in your Blender and show me a screenshot of how the viewport looks when you enable GLSL ?

i can see this by modifying your set up a little and being in GLSL mode
in 2.63 latest SVN


dont’ you see this ?

there was more problems in 2.49
but that’s not important!

i can see also color texture from UV in viewport !

salutations


here is another shot with shadows for lamp

Ah thanks, it confirms what i thought, in fact GLSL is not working on your computer.
What you see is exactly the same as what you would see if you had Multitexture instead of GLSL (switch to Multitexture and you see it’s the same in the viewport)

If GLSL was working, you would see in the viewport what you see if you press the Render button, not the blue normal texture.

not certain i understand what you mean here

see this example the bottom plane is UV map with some color but there is not normal map on this one

i can see the UV image in color in viewport !


so can you give another example
i know that with Uv map it may be more difficult to remove the bluish color
but you can still see the mapping in 3D with 3D texture in viewport from UV map
is not that GLSL ?

salutations

GLSL allow you to see in realtime what you use in the Materials, that’s especially usefull when you use normal maps.

Another .blend example :
http://www.pasteall.org/blend/13451

If GLSL was actually working on your card, what you would see in the viewport when enabling GLSL is what you’ll see if you render the models, both sphere would have a rock texture on them, and one of those sphere would even had some kind of normal effect on it.

But as GLSL does not work on the kind of Intel card used there, what you will see is both model using the checkboard texture from the uv/image editor, not the textures from the materials.

What you show in your screenshot would be the same as if instead of GLSL you switched to Multitexture.

So in the end, when you enable GLSL on card like g31/g33 , it is the same as if you enable Multitexture.

I have read that on linux they have the mesa opengl, that can actually emulate the shaders from GLSL on CPU for cards that does not have OpenGL 2.0, but on window there’s nothing like this apparently.

G31/G33 can emulate Direct3D shaders on CPU though (meaning that if you run a Direct3D application that has normal map, you would be able to see them in real time), but just not OpenGL shaders , mostly because Intel clowns never cared.

can you upload the rock texture
would like to make another test may be!

well i don’t really have another PC to check that with a good vid card!

but i tried with your last file and even in texture mode i cannot see the texture from UV image which is very strange
cause i have other files where i can see it !

but never really did a test with a normal map plus a color image
that i would like to test one with 2 textures and see what it gives!

but may be your right - if i had 2 computers i might be able to compare but i dont
so difficult to see what i should or should not have !

thanks

The rock texture is packed in the blend, go to the UV Texture editor and select the rocky.tga texture then save it.

sorry just found it at top of UV editor and save the file !

but why does it gives an error when you save external in file menu ?

thanks

In the UV Editor :

1 - select it :
http://i.imgur.com/apaUN.jpg

2 - Save it :
http://i.imgur.com/ReRNy.jpg

edit : didn’t noticed your edit.


is this what you mean or not ?

thanks for clarifying this mystery

Now one of the great thing with Cycles, is that it will allow to display in the viewport those material in real time, something that previously (i mean if using the Blender Render) required GLSL in Blender to be supported by your graphic card.

By example, this is the viewport of those 2 sphers if i switch to Cycles Render and set the display mode of the viewport to “rendered”
http://i.imgur.com/VgySas.jpg

ok but with the selected texture in the pic i uploaded
i was not in cycles just normal blender

mind you i don’t think you can see more then one texture which is the one selected in the UV editor

so still is the picture i’v uploaded good or not for GLSL ?

thanks