GLSL normal maps not working

I am having problems with GLSL and the game engine - Initially it just went black when I ran the game.

I fiddled with the “render settings” and in “shaders” selected GLSL and turned “Extra Textures” off.
Then when I run it I could see the textures and the lights work ok.
Trouble is with “Extra Textures” off I don’t get any normal maps on my objects.
Is there any way to get round this?

If I turn off my normal map texture but leave on “Extra textures” it works too - so maybe its the texture…
I set up the texture as an image
Under image sampling I checked normal map, Tangent
Under influence I Turned off color and checked Normal with a value of 1
It works on the 3d window but makes the whole screen black in the Game.
Anything I’m missing?

I’m using a 2.59 version of Blender
My graphics card is a NVIDIA GeForce GT 555m which is an open GL 4 card so I’m pretty sure GLSL should work ok.

#####Update####
strangely Bump mapping works ok - its normal maps it can’t cope with

Hello
post a little example file, maybe?!
Bye