GLSL Problems and Looking for a Water Texture

OK, I have two questions.

  1. What would cause that when I am using GLSL textures that all my objects vanish into thin air when I press P?
    The normals are facing the correct direction, and it doesn’t happen in Multi-Texture mode.

  2. Does anyone know how I can make a texture for moving water in the GE? Does It have to do with Displacement and certain file extensions…?
    If not, what is a good alternative?


Content has been removed. MayDev

  1. There are Texture-face, Multi-texture and GLSL mode. Choose either 1. For bumps (water) use GLSL.

  2. You can try fading 2 procedural image on top of each other (eg: voronoi, marble, etc). Render it to a plane to get the image file.

if you click on the shameless plug mayhem put in and decide to use that script I created some water textures a looooong time ago (although with a normal map generator, or a sculpt-over would be required to get normal maps)

I believe they’re here

just click the link in the left for animated textures (i even made some ripples :))

Content has been removed. MayDev

My bad mayhem, forgot you didn’t really “know” me. hehe my apologies.

Content has been removed. MayDev

It’s because you trolled my post about macs. I had to complain somehow to you. And it appears it worked :slight_smile:

Content has been removed. MayDev

Different strokes for different folks.

anyway guys to answer your question glsl mode needs a material applied to the object and add an image to the material

I forgot to mention… I’m usin’ 2.53, not 2.54. Sorry.
Also, I do have a material for my stuff, but when I press P, it disappears, yet I can still see their collision bounds and whatnot.
I tried using you blend file, killer, but it wouldn’t work, so it needs to be 2.53…
Thanks for trying.

How are your textures mapped and what’s your lighting setup?
i can upload the animated map as well, but follow the tut anyway

and considering that blender 2.55 is out why not use that?

Just downloaded 2.55 and they fixed the animated normal maps :slight_smile:

yes. i hope that helped

OK, I will try 2.55…
But my lighting consists of a single Sun Lamp at an angle, and most objects have an emit of about .2.
Textures are mapped via UV, with an image texture that has UV coordinates.

Wait, what blend file? Are you referring to the UV scroll script? If so make sure you’re downloading the right one. There’s a 2.54+ version and a pre 2.54 version. Make sure to download the pre 2.54 (it should work in 2.49)

I tried following the Yo Frankie tutorial, I made the normal map, but for some reason, It won’t displace the surface! What could I be doing wrong? (I followed the tutorial with 2.55)
Additionally, my plane disappears when I start the game engine!
I just don’t get it!
I also did download the pre-2.54 script. Is there anything I should know about using it other than just pressing ‘P’ to test it?
Do I have to enter any additional values?