GLSL Rendering Issues

Hello. A friend and I have recently begun making a game, and have decided to make the switch from Unity 3D to the Blender Game Engine. So far everything has been great, but recently I have encountered a few issues regarding bothe GLSL rendering and rendering in general.

My first problem is this. When i observe my textured object before rendering the game, everything looks fine and awesome and peachy keen. However, once I switch from Multitexture mode to GLSL mode, I lose all of my colour variation and everything is shown as a much lighter, warped, and untinted version of the texture.

The first image is how my tunnel appears in both Multitexture and Singletexture mode before being rendered. The second image is how my tunnel appears in GLSL mode. As you can see, there is quite a drastic change.

I am unsure whether my graphics card (Radeon HD 6520G) is incompatible with the engine (I also updated the driver to ensure that everything was up to date) or if my settings are incorrect in the engine. I have sent the .blend file to another artist, and he tells me that everything appears alright to him. This has lead me to assume the former.

Thank you so much for any advice you can give me. Many a stress has been had, so I am very appreciative. =)

*** Edit ***

I forgot to add, I am also having an issue when rendering the game in Multitexture mode. While I was going crazy over my GLSL issues, I reached a point where I decided to render the scene on a setting other than GLSL, hoping that it would look okay, and that I could carry on with my Blendering life in some other manner. However, that was not the case. Instead of some nice looking tunnel like the one that I posted above, I got this.

All of my textures vanished, and I was left with this smooth and slightly shaded thingamabob. i honestly don’t know where I went wrong here. This far I had followed a tutorial up to the T.

It looks different in GLSL because… well, that’s what it does. You must not expect it to look the same in two different Rendering Modes.
You simply have to choose beforehand and design all your Materials so they look good in the Mode you actually want to use.

It is brighter in GLSL because the Lighting/Shading are handled differently. You can, in the Rendering Options, also deactivate “Color Management” – that will speed up GLSL a Bit but also make Lights and Materials look different again. In any Case you must know what you want beforehand or you will need to change the Materials afterwards.
The shiny Spec in GLSL Mode can be deactivated (set to 0.00), or you use the Texture to also affect the Spec.

Ô, and the Stencil Textures, I suggest you use a Node Material to emulate those – I love Node Materials for the Freedom one gets with them, but they seem confusing in the Beginning, I guess.

This is a shot in the dark, but have you checked the size of your specular?
Also you can either disable it all together or enable texture’s specular to avoid large specular areas.

I understand your point, but I do not think that things should look this different when switching modes. Here is an image of the same scene in GLSL mode from someone else’s computer.

I do not mind the specular shine that is going on. Once I get things working, I plan to decrease it.
Also, do you happen to know anything about my second question past the edit mark? If I can get this fixed, I may just dismiss my problems with GLSL.

Without a .blend to play with it is hard to say what the problem is.

How many textures do you have applied to get your effect in Multi-Texture? It looks like GLSL is different because it is missing some texture levels and because it does the specular lighting “per pixel” instead of per-vertex.

Sorry for not really having understood the Trouble. But indeed, that is weird. (Have you also tried different Blender Builds and Versions? (Maybe you were unlucky and picked a very unstable Build?) Or have you both the same Blender Build? (recommended for Teamwork, obviously))
Looking at the Texture and nw knowing that all the Details are Part of one Image… are the UVs set properly? Is the Texture properly set to UV in the Texture Tab?

For the second Problem, I am even more confused because it sounds to me like you first made it in Multitexture, set it to GLSL, set it then back to Multitexture (“other than GLSL”) and suddenly the Textures were nomore – id so, I couldn’t say anything about that, I’d be rendered speechless in the Face of utter Puzzlitude… o_O … or I just misunderstod you.

Here. See if this helps. this is the file for the blend. i do believe that I have my textures set to UV, and my second problem is caused after starting the game engine on multitexture. Let me know if you find anything, and thank you for your help.

Official blender 2.67b


GLSL (with material specular turned off)

In game view the multitextured looked correct and matched the GLSL in game view when the GLSL material was set to shadeless.

Well, if it looks all fine to you and the other person I have shown it too, it is most likely that my graphics card is simply incompatible. I may just stick with Blender for meshing and texturing, leaving the whole engine ordeal for some other product. Thanks for the help. At least it kind of cleared up my situation. :stuck_out_tongue:

I get the exact same Results as Richard Marklew. It might something to do with your Computer indeed then.
By the Way, I’d remove the first Texture that literally doesn’t do anything. And especially I would remove that (I guess unpacked) TIF Texture. You are not supposed to use TIF Images in Games, those are for Printing! In Fact, maybe these two (useless) Textures could have caused a Bug leading to your Issues – I’d have no Idea how, but it could be considered.