GLSL Texture problem

Hi. I am in the process of making an old western horror level. I have uv textured the objects and I have made a material for the objects. But when I choose the coordanance to be set to uv, it works for one texture but if there are multiple textures on the object, only one texture shows. Any help will be much appreciated as this has been bugging me for a while:mad:

for more than one texture you need to be on GLSL, and eatch texture needs to be set on its respective UV.

I have done this. But it seems the first texture I set to UV overides the other textures that I set to UV for a model. Could you maybe post a blend file of the correct way of doing it so I can compare it with mine.

if you have multiples uvs they need to have a reason to be, for example, I have the difuse, the normal and the AO textures, the difuse need to be adjusted on the map input to col, the normal need to be adjusted to norm and the col need to be desselected and for the AO you need to use the col but on the mode you need to change from mix to overlay.

I have tryed the options but still cant get it to work. It might be my graphics card. I have found another way to do what I want. My graphics card can still support GLSL though.

Thanks for the help.

I used to have the same problem. What i did was this.
Go into you image editor(outside of blender) and make your workspace huge.
Now simply spread all your textures around on the giant workspace.
Then go into blender, open the new BIG image and reposition your UV’s.
As you can see in the image below, i used to have 6 different pictures (represented by the red circles). But now they fit into one big one.
Hope this helps. that way when you add materials, you only have to add one texture… and i guess normal maps.


Hey that is a good idea. I might use it with some of my buildings. I also had a thought that maybe my problem is caused because I set the uvs in mutitexture mode and then shifted it across to glsl mode.

I have another question. How would I put all the textures into one big picture in gimp. I have very little experience with using gimp.

Create new image, set to 2048x2048 or something, then just drag&drop.

cool. Thanks