GLSL texture problem

hello everybody,

I am more or less new to blender. I was working with blender many years ago and just started over again. However, a lot of things have changed but mainly the interface.

Anyway, I have been stuck with a problem now:
I started modelling some objects for a game and gave them textures. All set with the shading method to “texture face” and in the uv-editor.

Then, I needed water for my game, followed a tutorial and set the shading method to GLSL. Since then, the textures in the 3d-view are not shown properly. The objects are shown like without textures even if textures are switched on. Furthermore, when I start the game for one object the textures are shown right, but for the other object the texture is not the one I assigned!

Does someone know what could be the problem?

Thanks in advance for your help!

p.s.: I would thank you also if you could send me a link to a good GameEngine water tutorial.

PPS: I’ve noticed that when I assign a texture in the texture properties menu (not uv-editor), upload the right texture and set mapping to uv the texture is shown right. But that leads me to another Problem: My objects have at least 2 different textures, some even more. When I assign the texture with the texture properties menue I can only assign one texture for the whole object… right?!

Im pretty sure you can have multiple textures, isn’t that why there’s the option to keep adding textures? Also make sure console isn’t outputting any errors when you switch GLSL on, I have a gCard that supposedly has full support for GLSL but on my Ubuntu the driver misbehaves and I can only have 1 or 2 glsl textures at a time or else my view in AND out of GE gets screwy. Try setting multiple textures see what happens. And if you use a UV texture definitely always set the texture ‘mapping’ to UV coords.

ok, thx for the fast answer…
I saw, that it is possible to add a lot of textures but then the textures are applied for the whole object… imagine a surfboard… for the top of the surfboard i selected te topfaces an loaded a texture for it in the uv-editor… then for the bottom i did the same just with another texture. then i changed to glsl and it didnt work anymore.

By the way, how can I enable the console, it is hidden with my blender?

To enable the console, select the option to enable the console in the Help menu. To apply different textures, you need to ensure that you have a material on the object you’re texturing, and that the textures all use the UV-map for Image Mapping.

ah ok… that means, if before i had for one object 2 or more textures, now I have to join these textures to one file?

This would not be very handy…

And if I want to apply a texture - DOES it need a material? or can I add just one?

You don’t have to merge textures - you can have as many as you want in 2.5 (I think). Also, yes, it requires a material to apply a texture on an object in GLSL mode.

^^^ He is correct, I remember doing some texture testing for a low-poly human model, I was able to use 2 different textures as long as the the 2 were two
different sets of UVs for the object, I had one for the neck up, and another for the the rest of the body