GLSL Textures black?

Hi all

I have been learning how to texture map objects in Blender (I’m a complete novice since I have focussed totally on Python :evilgrin:) and I have been using multitexture mode to do this:


I’ve been using PNG’s with transparency and work just fine. Just for laughs I swapped over to GLSL but then got this:


The textures are lit (and obviously visible) but the alpha channel does not work- I have not changed any other setting between GLSL and multitexture, what am I missing? Can I use PNG files with GLSL?

I’m grateful for any advice!

Cheers for your time

Paul

PS I attached the file below in error and I can’t get rid of it- sorry!

Attachments


I get this too in the regular 3D port with OpenGL enabled, its like a clipping issue. I thought that it was just a driver problem for my video card. My system is a PC Win7, not sure of memory or graphics card of the top of my head. What system do you see this effect on?

There are a few extra steps you have to take with GLSL transparent textures.

  • Have your alpha-needed object selected
  • In the Textures tab of the Properties window, scroll down and enable “Alpha:” under “Color:” in the Influence section.
  • In the Materials tab, scroll to the bottom and enable “Transparency”. Move the slider all the way to 0.

It should be good to go now.

MichelleSea> nice! just missed one setting! All fixed now:


Thanks for the help!