Good render-script/batch for MAC osx?


I can work pretty fine in blender but I’m not able to find this out for years so I ask your help please.

Does anybody know a good renderscript for Mac osx (intel) and how to use it?

What I want is to make a batch render without opening blender, so I can render a cue of severall scenes in the night. Now I’m redering in blender itselve and when done I open a new scene manualy. I like to drop al the files/scene in one aplication/script so it renders all in a row, without having to take care of it.

Hope you understand what I mean cause i’m not so good in englisch.


I don’t know of any.

you could build one with Applescript or Automator, but you’d probably have to go through bash (the terminal) in any case. So, inside Applescript, it would be necessary to do something like this script, which I use for just starting Blender:

tell application "Terminal"
	do script with command "/Applications/blender-2.49b-OSX-10.5-py2.5-intel/ -p 0 0 1440 880"
end tell

Bear in mind that there’s a path in there for Blender on my system, so it probably will have to be changed for your system. Rendering a file would be something like:

tell application "Terminal"
	do script with command "/Applications/blender-2.49b-OSX-10.5-py2.5-intel/ -b /path/to/blendfile.blend -o /path/to/render/output.png"
end tell

In Automator, you’d also have to go through the Terminal, as Blender is not Automator ready. I think, without testing, that you’d need to drag a shell script into your automator flow, then do like above minus the Applescript stuff:

/Applications/blender-2.49b-OSX-10.5-py2.5-intel/ -b /path/to/blendfile.blend -o /path/to/render/output.png

Haven’t tested these, but they could be a starting point. I’ve written small Applescripts before, but that language really gets my blood pressure up. If you can find a willing Applescript guru, it should be possible to do a GUI where you can make a list and just drag .blend files from the Finder to it, then press “Go”.

I’ve not tried it myself but this may be of interest.


Just tried blender++.
I am not sure if I am missing a step but Python returns this error:
“LinuxOSX/Blender++/brend95.pyw’: [Errno 2] No such file or directory”
It appears that only is included in the download. Anyone got this to work in OSX?

Have you installed the correct version of python. It is not the version of python that ships with OSX.


Yep installed Python 2.6.4 and wxPython 2.8

Well I went to the source, here’s a reply from Akta:

"Yes you’re right, there is a minor bug on Blender++ with OSX. It has been solved in 1.2 which will be released in few days"

Looking forward to the new release