Google Maps Models Importer

Hey, I have a question. Is it possible RenderDoc created a map based on something other than google maps (e.g.: https://zdjeciaukosne.gliwice.eu/ press “ORTOFOTOMAPA” to change “MODEL 3D”)? Of course I tried, but I stopped at Blender:

IndexError: list index out of range
Skipping ([Errno 2] No such file or directory: 'C:\\Users\\...\\2-i5elwu4\\2-00000-uv.bin')

Anyone have an idea?

Welcome to the community.

Technically I don’t know if it could be done. Maybe the data fetched to Blender isn’t like that from google. I think the only one who could help you is the maker of the addon. @Mink

I had a quick look at the website of those guys who made the model. They’re making some pretty cool lidar photo scanned aerial stuff. I think you would get into some copyright problems if you use their data for anything than personal projects. Keep that in mind.

Thanks, is this a code to insert inside the google chrome properties? where does this text should go?

Hey guys,

I successfully used this amazing addon a few times already … thanks for all the work @Mink! Much appreciated!
Now, after half a year of not using it, its time for another Google Maps capture.
But somehow I can’t get it to import anything. As far as i see the captures with Renderdoc are working, but the import with the plugin is not. I also tried importing old captures that i knew worked previously – to no success.

I get this error message:

Invalid RDC capture file. Please make sure that:

  1. You are importing from Google Maps or Google Earth web
  2. You were MOVING in the 3D view while taking the capture (you can use the Capture after delay button in RenderDoc).
    Please report to MapsModelsImporter developers providing the .rdc file as well as the full console log.
    Console log is accessible in Windows > Toggle System Console (right click to copy).

this is the log in the console:

Traceback (most recent call last):
File “C:\Users\manuel\AppData\Roaming\Blender Foundation\Blender\2.83\scripts\addons\MapsModelsImporter\google_maps_rd.py”, line 27, in
import renderdoc as rd
ImportError: DLL load failed: The specified module could not be found.

Seems python is not able to import the renderdoc DLL … did anyone else have this before?

Hola

First I want to say that this is one of the coolest projects I’ve seen for any 3D artist, specially if you are an architect, like me, so thank you.
Second, I need some assistance, I’m using an Nvidia 1080 GTX, and i haven’t been able to import the rdc to blender,
this is the error Ierror get

and the rdc file https://www.dropbox.com/s/yx4ik8zosg4anz2/naucalpan1.rdc?dl=0

Thank you.

So… posted this message on the github page, but it feels to me this thread is much much more active, so I’ll give it a try here :

Hey there.

So… I am a mac user, but fell in love with the idea of being able to capture Google Maps 3D models… So here I am, trying to make it work on a virtual machine. It’s not fully working yet, but I’ve been able to do a few things… Would like to hear from you about a few issues though.

I did manage to get so captures with older versions of Chrome and RenderDoc. Here’s one : https://cp.sync.com/dl/5578fa7f0/w8v8xjfp-qsmcefud-39zdbryp-nw9j7yks

I am not able to import any of those in Blender tho. Always get the usual “Invalid RDC capture file…” error msg.

At first, I thought the captures were the problem, since RenderDoc throws a “warning” when capturing… (Something like "Couldn’t create FEATURE_LEVEL_11_0 device … "

But then, I stumbled on your sample rdc file (capture.rdc) and gave it a try. Same problem arise with your capture… So I’m now thinking my captures might be ok, and the problem would only be related to the Blender addon…

Tried opening the capture.rdc file in RenderDoc and got this in the Diagnostic Log :

Any thoughts ?

Can at least anyone try to import my capture (eglise.rdc, from the first link above) in blender to confirm if the capture itself is ok or not ?

Many thanks !

J.

First of all, I’d like to thank @Mink for the awesome plug-in!

I am experiencing some of the same problems described in the comments above. More specifically: I successfully used the plugin on September to capture from Google maps and import into Blender 2.83. I tried again yesterday to capture and import things from Google Maps into Blender (updating Render Doc to 1.10 and the plugin to the latest release).

I could not import any of the captures (the new ones and/or the old ones) in Blender 2.90, resulting in the same error as @ManuelGrad. I tried to import things in Blender 2.83 (which I luckily kept installed): old captures were still imported with the updated version of the plugin, but new captures did not. Then I realized (going through the ‘Troubleshooting’ part of the GitHub page) that I forgot to click on the Earth icon in Google Maps and activate 3D view before doing the capture. Once I did that, new captures were correctly imported in Blender 2.83, but I still got an error in Blender 2.90 (same as above).

I hope my experience might help (and that there will be soon an update that lets me use the plugin in Blender 2.90)!

Cheers,

Alessio