Google Maps Models Importer

I was able to test and succeed with a 1070, so if it is not too much pain, try switching the display to the 1070. On this machine, the webgl chrome/gpu info was “Hardware accelerated”, no reduced performance.
I have a machine on which I haven’t been able to start chrome with the right flags, I don’t remember exactly why, I’ll give it another shot, as it may give ideas.

I’ve tried setting my 1070 as main display and even thou chrome://gpu reads as everything hardware accelarated, there is no change on the flag, it’s not allowed.
I’ve tried with --no-sandbox to disable sandboxig all around and the same thign shows that it’s not allowed. So it has to be some stupid security flag somewhere, but I can not find it, also it’s the same in all my computers regardles of hardware and chrome version

I’m so excited by your work !! What a great job you did Mink, it’s really amazing.

Unfortunately, i doesn’t work for me… after putting the flags in the target of chrome, the 3D view of google maps is disabled… i don’t understand why ??

Do i have to enable something in the settings of chrome ?

I’m working with my laptop, perhaps it isn’t powerful enough and the 3D maps is automatically disabled… ? I will try tonight on my PC and will debrief here again !

That was it, my laptop graphic card isn’t powerful enough. It’s working great on my PC ! Many many thanks !!

Hi @Treno_Notte, glad you succeeded! :slight_smile: For the record, could you let us know what GPUs you have both on the laptop and on the PC?

Hi @Mink

GPU of my laptop: Nvidia GeForce GTX 765M
GPU of my PC: Nvidia GeForce GTX 970

I have one more question: is it possible to regroup all the textures of the 3D image imported in Blender in only big one easily ?

Cheers !

The test file works fine, but when I try to load my own files in Blender, nothing happens. I also get the following warning in RenderDoc - any idea what it means?

@Treno_Notte thx for the feedback. FTR I had it work on a GTX 1070 and could not on a GTX 745.
For texture packing into a single uber texture, this can be solved by writing a simple Python script completely independent from the capture process and run it afterwards. You can use the PIL library for image manipulation.

@plundh You are the first to report such an error. Given its severity, it explains why there is nothing to load in Blender. I am not sure exactly what can cause this. Is RenderDoc correctly injected? Which graphic API does it say it is using in the “chrome [PID xxxx]” tab?

Ok, finally I got it working.
Once the 780 got unplugged and closed any other chrome running stances I got it to work on the 1070 even thou the same message that the flag is not allowed is still showing, renderdoc and chrome worked as expected, so thanks a lot for this awesome tool

Unfortunately, I’m stuck on the Chrome flags. I’ve copied and pasted chrome.exe --disable-gpu-sandbox --gpu-startup-dialog --use-angle=gl into the target of chrome shortcut, but I’m not getting the predicted result as shown in the video. Instead, it just opens chrome as if nothing changed.

Tried later on Chromium. Success on the chrome process initiation, but Renderdoc keeps crashing shortly after injection.

Edit: Got it to work on a different computer. Will post again after testing a few things.

After a few more rounds of testing. I am now stuck on opengles not registering.

Hi @Colacuve!
I edited the first post to start listing the GPUs on which it works and those on which it has been reported not working. Because unfortunately it seems that the process injection is not working everywhere.
Can you report the hardware used for your tests? Thanks!

Hi @Mink
Your addon seams like great feature but I have a problem.
I made every steps of your tutorial without any crushing or problems, but when I importing rdc file to blender it’s empty file. File’s size (70mb) assuming that there’s some data, but nothing showing in blender. I tried with different location but nothing showing in blender anyway.
Do you have some advice or solution for that?

Oh, and I have 1050ti

Hi @ADlug, it seems that you are bumbing into this issue. The solution is simple: download an older version of RenderDoc. If the 1.2 does not work, try the portable version, or even the 1.1.

I had the same problem and to use RenderDoc 1.1 solved it. Thanks a lot for your script !

It worked with GTX 1050ti on RenderDoc 1.2. It did not work with GTX 1060.

@Mink
Thanks, It worked! I tried find the solution by myself but I didn’t notice that on github :slight_smile:
So I’m reporting it works on 1050ti and RenderDoc 1.2

Thanks again for your script.

Thank you for your feedback, I added your GPUs to the list!

I’m skeptical to believe that a GTX 1060 cannot handle this. I reported that it does not work because RenderDoc did not report a connection to OpenGLES when attempting to try it with google Chrome, using the specified flags. It injected properly, but the overlay text in chrome window that you would see in a successful connection did not show. Any ideas?

The resources I downloaded didn’t work out with my windows laptop. There’s no need for me to waste time worrying if it works or not. It least I tried. Good day

@Colacuve I understand and share your skepticism. What makes you say that it injected properly though, if neither the connection to opengl nor the overlay text appear?

You may try to disable your browser extensions, somebody reported this solution to work in their case.