Google Maps Models Importer

Hello,
Amazing! unfortunately it doesn’t work on my laptop. When I try to inject into process renderdoc crashes. Also google earh refuses to load when I open chrome with those flags.

Seems like my intel HD 520 wasn’t built to handle it (obviously) so I tried a different idea instead. I installed google earth pro, deactivated all atmospheric and other effects and switched from directx to openGL. Instead of inject into process, this time I tried “Launch Application.” It almost worked! Renderdoc didn’t crash and everything seemed fine from that end. But over google earth pro, render doc showed this error: “OpenGL. Context not created via CreateContextAttribs. Capturing disabled. Only OpenGL 3.2+ contexts are supported.”
Here’s the screenshot:

Registered just to post this message.

I finally got this working. Renderdoc 1.2 portable, an old version of vivaldi from this archive https://vivaldi.com/download/archive/ and the same batch file/command. I just went back to 2017 and grabbed a random one. This is the one I used: 1.12.955.42 (Stable channel) (64-bit)

Exactly the same command to launch it, but with vivaldi.exe rather than chrome.exe at the start. No crashes or second requests for the id - all worked perfectly.

2 Likes

Plugin doesn’t work with Blender 2.81 :frowning_face:

When trying to import capture.

@SquareRoot Thanks for the feedback, I just updated for 2.81 https://twitter.com/exppad/status/1198183557254004736

@Throwaway999999 I found an installer for an old enough version of Chrome (70.0) that works: https://www.slimjet.com/chrome/download-chrome.php?file=files%2F70.0.3538.77%2FChromeStandaloneSetup64.exe

@Mink

Awesome works again! :+1::+1::+1:


one more thing for anyone else.
if you open the rdc and it creates texture folder. you can’t open the same rdc anymore it will crash you have to delete the texture folder. than open rdc again. or just pack it all into blend file.

I got it working again too, thanks so much Mink!
I’m finding that Chrome is updating itself automatically so i need to reinstall chrome whenever i need to capture, is there any way around this?

@SquareRoot Thx for noticing the “loading twice” issue, maybe open a ticket on github: https://github.com/eliemichel/MapsModelsImporter/issues

@Dr.J In my experience it updates only if I go to the “About” section to see the current version. Yes, this seems like a stupid design: it changes version whenever you want to look at the current version number…

будет потдержка видеокарт 1650 или p1000 или p2000

there will be a support of video cards 1 650 or p1000 or p2000?

Hello, me again. This time I came to say that everything works great. (Blender 2.81, Vivaldi 1.8.770.54 x64).
Sorry for my lack of communication in the past.

Question: Is there a way to capture a larger area and/or force the maximum level of detail to be loaded in the area one is capturing?

@111175 There is no plan of supporting any more video card, as it does not really depend on me.

@John_514 Thanks for your feedback, you can change the browser scale to fool Google Maps into thinking you have a larger screen and hence need more details using Ctrl+MouseWheel. :wink:

2 Likes

Edit - spoke too soon again, just had to increase the block limit. Your suggestion works :slight_smile:

how do you increase this block limit? thanks!

In Blender 2.8 at least, when you select what RenderDoc capture to import, its on the top right. Default is 200.

ah ok, never noticed that before. thanks a lot!

Getting an error on a 1060 6gb GTX. I’m pretty sure I have some mesh data but textures are all black and render doc tells me something is wrong with the hardware. I haven’t even tried importing this into Blender since I get 0 textures in RenderDoc, if anyone has a fix hit me up ;). And if anyone would be kind enough to extract something for me that would be absolutely amazing!

In Google Map, try to move your viewpoint for the entire duration of the capture. Literally just grab the view with the mouse and go back and forth like mad starting before you press the capture key and ending after it has completed capturing. I had that exact same issue and fixed it this way.

1 Like

I´ve been trying the addon and works good when I capture from a zenith angle. If I lower the camera a little I, the blocks get imported in a displaced manner like in the picture. What could it be? Im using blender 2.81, renderdoc 1.2, vivaldi 2.8.44, windows 10, gtx 1080
Edit: I’ll try older versions of vivaldi to see if that’s the problem.

I did the capture but I am getting this error message when I try to open it:
“Failed to open capture for replay: API initialisation failed.”

I am using AMD Radeon RX Vega M GH GPU
What could it be?
You can have a look of the Render Doc log here

I’ve had the same issue sadly :7

@Colacuve hello together, was wondering if that issue with (not registered) was solved with a gtx1050ti instead of 1060 and if you used the same software versions of renderdoc & chrome? thanks in advance…