Goz for blender 2.8

Still doesn’t work for me
Windows 10 X64 pro
ZBrush 2019.1
Blender 2.80 beta latest
I rename the GoB 3.0.4 folder to GoB
Copied the blender folder that Gob folder contains, inside C:\Users\Public\Pixologic\GoZApps
Push export button inside Blender
nothing exported to ZBrush

Did you tried to export from Zbrush using a mesh from his lightbox? I needed to export from Zbrush to Blender before anything, otherways exporting from Blender didnt work the first time.

No luck either. This is what happened when i click GoZ inside zbrush:

I had the same issue. What helped me was to go to Pixologic\ZBrush 2019\Troubleshoot Help\ and reinstall GoZ with the installer there: GoZ_for_ZBrush_Installer_WIN.exe

Then I set everything up again in ZBrush and it worked like charm. :slight_smile:

I uninstalled zbrush and make a clean installation of zbrush 2019.1. Previously i had upgrade the existing installation. Now GoB works (both ways).

1 Like

Hi. What is my problem? GoB from Zbrush to Blender and from Blender to Zbrush work perfectly! BUT Mesh that imported from Blender to Zbrush is NOT Subdivided

  1. It is subdivided because number of points is growing…BUT.
  2. Mesh is not changed (it is still loks like Low poly!)
  3. Slider of Subdivisions is inactive

In case importing mesh as .obj …everething is Ok!

@aghandwork it should export what you see in blender, can you attach a blend file where this happens or a screenshot with the modifier tab visible?

there is a option in the addon preferences what should happen with modifiers, maybe your is set to do nothing and thats why your subdivisions are not sent to Zbrush. make sure to set this to Only export or export and apply if you want the subdivisions applied in blender as well.

Thank you for your reply! I was playing with all parameters and trying to find out what problem is…and that problem definitely not at the side of GoB, everything work good!.. My problems exactly in mesh that I have (because all other meshes work as it should!)…only this one have some constraint (which I do not understand)

Conclusion: GoB work - wonderful! If you will have free time to play with my mesh here it is https://drive.google.com/open?id=13CWnHROz5bM5-DVe8jDBg4Y8W5SQcteC

Latest Blender (11-June) crashes consistently when exporting from Zbrush to Blender using GoZ…anyone else have this issue?

@mrgesy i häve not tested that version, i will give it a try in the evening. Do you get any error or blender just crashes silently?
What does you export from zbrush include? One single subtool or multiples? Do the meshes contain any data like uvs, polygroups, polypaint or so?

I exported a new, single cube from blender with GoB. In Zbrush I subdivide it to around 90K polies, I press Ctrl G and Blender crashes silently in the background. No warning, nothing. Mesh has no data except default UVs.

Can confirm this. Blender doesn’t crash if you first press GoZ in Zbrush, and then toggle the “Import” button in blender, then it imports successfully. If the button is pressed in blender and you try to GOZ from Zbrush, it crashes. Essentially you have to disable “import” every time you want to GOZ something from Zbrush.

@mrgesy, @Hickz thanks for reporting, i get the same crash. i will see if i can figure out why this happens.

EDIT: did you by any chance update to zbrush 2019.1.2 ? i seen that they did some changes to GOZ so maybe that would be why. i am on the latest version but will install 2019.1 to see if it crashes as well and its something on the addon/blender side.

Actually no I havent updated to latest Zbrush. Will update and test this

its not the zbrush version, i tested with the old version and it does crash as well.

@mrgesy @Hickz there is a new version 3.0.5 which should fix the issue, you should be able to update it in the GoB addon preferences.


Just tested it. Works great! Thanks for the fix!

Plugin version: 3.0.5
ZBrush version: 2019.1.2

I tried every modifier option and I still can’t export from Blender back to ZBrush.
I always get this error message.


@matejkovacic are you using the latest nightly build of blender?

@kromar yes, it’s the latest blender-2.80-0fd96b4128ff-win64