Goz for blender 2.8

Your problem suggest that you do not have latest blender build.

context.evaluated_depsgraph_get - was added in blender 2.8 few weeks ago.
If you use latest daily build it will work ok.

1 Like

@kromar and @JoseConseco thanks, guys. It works! I have multiple blender versions installed and somehow I was pressing the wrong icon… :blush:

So Ive been reading everything on this post. For my first time, Gob on 2.8 does not want to be enabled. I do see the box and the information and everything but it’s not letting me check it off. The console keeps telling me "add-on not found: “GoB”
The file is installed in the right place and the folder is renamed to “Gob” since “Gob-3.0.5” will not find anything in the add-on section. I also tried deleting the Blender folder inside of the Gob folder. Then when I do remove the add-on the console then says “add-on_utils.disable: Gob not disabled” I even restarted my computer after doing all this. This is driving me nuts, please help.

Never mind, found my mistake, I originally downloaded it to my mac and bluetooth’d it to windows. Big mistake, the mac deleted or did something with the files, downloading it from windows fixed the problem. Im going to wear a dunce hat now. :smile:

1 Like

IS it Knowing issue? I can’t find the error. Please, let me know.
Trouble to Use.
2019.12 zbrush
blender2.8 last one…
Thanks a lot this Addon.

Thank you I found the Last version GoB 3.
'It Is Work ing Well~
I used GOB 2.0…sorry…
:smile:
https://github.com/JoseConseco/GoB/releases/tag/v3.0.6

2 Likes

Link is not working :worried:

@Woolfy13 you can find all the releases here https://github.com/JoseConseco/GoB/releases
I had to change the tags which broke the previous links.

1 Like

Thank you very much for the link! It works nice!

1 Like

Everything works as expected except the model comes into Blender with Y back instead of forward. There is an option to flip Z(which is upside down by default) so can you add one for Y too in the addon prefs? I don’t want to mess with the native importers in either Zbrush or Blender because I’m also using Max with ZB>Max Styx bridge already working perfectly. I now have a perfect Max>ZB>Blender bridge pipe with no scale issues, with the Y back in Blender being the only issue.

Thanks for this. It’s great.

@Musashidan have you tried the up axis flip option in the goz addon preferences? It solves the issue for some.

As I said above, it’s a forward/back axis(Y) issue. Both axis are flipped and there is only an up/down(Z) option in the addon prefs.

I made a fix for this some time ago because the forward axis was wrong. Should have made that a feature back then:D

It would be helpful alright as it doesn’t really work otherwise. :smiley:

@Musashidan i added the option, would be great it you could try it and tell me if you encounter any issues with it.
https://github.com/kromar/blender_GoB/archive/feature/forward_axis_flip.zip

2 Likes

All good mate. Just tested. Much better, plus you’ve added smoothing support. The only issue now is flipped normals when imported to Blender. This I can live with though. Thanks.

hm strange i did quite some testing on this. which options do you have enabled when the normals are flipped in blender?

EDIT: hm i think i have double sided enabled in blender but cant figure out where the option hass gone in 2.8 haha. i guess that explains why it did not happen for me^^

@Musashidan the flipped normals should be fixed now: https://github.com/kromar/blender_GoB/archive/feature/forward_axis_flip.zip

1 Like

Did you find a way to disable double-sided view? :smiley:

@Hickz i used the “backface culling” for it, since it does the same thing i think it was merged with the double sided option. do you know if the double sided is still somewhere around?