gpu detection fails on linux

hi all

Last days I’ve upgraded my gpu to geforce 750Ti with hope I’ll be able to rander with gpu finaly.
However my blender still doesn’t list cuda in compute device’s combo box.
I’ve tried blender from distro’s repo and from blender’s site.
I have proprietary nvidia drivers (331.79 version)
and I’ve installed nvidia-cuda-toolkit.
What else should I check, or do?
I’ve found this thread on stackexchange about same issue and It looks like it should work for me…

Thanks in advance

This happened to me on Fedora, which distro are you using. I know that the devs have looked into it, as I put in the bug report on it. But I don’t know when it will get into the builds? You can try downgrading your driver or do as I did and install a different distro, I installed Mint 16 and it fixed the problem (driver version 319). Or you can wait for the fix which might be better in your case as the 750 uses the Maxwell chip and it might not be supported in the older drivers.

Hi Kicer, Blender 2.70 doesn´t support Maxwell cards, try to get a build from:

builder.blender.org/

Cheers, mib

Grimm: I use Mageia. I’ll report a bug then as you said.
mib2berlin: I’ll check it this evening.

thx guys

Moved from “General Forums > Blender and CG Discussions” to “Support > Technical Support”

mib2berlin: blender from you links works. Does it mean, official releases do not support my gpu, or have some bugs?