GPU render brighter images Than CPU

Having an issue. GPU is rendering brighter images than CPU. And GPU+CPU is all messed up. Blender 2.80 Official Buid. Windows 10. Radeon Pro Duo Polaris.




:scream: Crazy !

Sorry I have no clue, except from the fact that… Blender prefers Nvidia than AMD :wink:

See you :slight_smile: ++

1 Like

It does not do it on all my projects. That is what is strange.

Really ? :thinking:
What about sharing a blend to see if it’s consistent for us as well ?

I will try and upload a portion of it. Maybe in the next couple of days.

Are you using an IES light texture?

Hi ,

No. I am using Blender area lamps. No IES.


Other things to check:
Is there a particularly weird shader on those walls?
Any other sources of light?
Branched path tracing or regular path tracing?

surface multiple importance as i recall correctly

It happens on other parts of the rendering with different materials as well. The metal shader is very simple. I am using an evening HDRI for global illumination. Using Path Tracing.

Do you have denoising enabled?

CPU rendering will give you different results then GPU rendering. CPU rendering is the ‘accurate’ render. GPU is the very very close result. That’s what I read a while back anyways.

No, those should generate equally lit up images, even though gpu rendering does not support some things but cpu+gpu makes it so both stuff is same on both renderers.

I’ve got such problem on 2.79 back in the day and it was caused by lack of support of multiple importance for lights on GPU, whereas on CPU it was going normally.

Yes, I do have it enabled.

I have this same problem. I use blender 2.90.1 and GTX1070. This is the first time it happens to me. Anyone has found where could be a problem? Also, there are vertical lines that shouldn’t be there. image

If you are using Adaptive Sampling and GPU+CPU rendering, this is a known issue.

I’ve turned it off and restarted blender but it didnt hepl.

Does that mean the problem still occurs with Adaptive sampling off?
If so, you check if the problem still occurs in blener 2.91.0 Beta:

If the problem still persists, you report the problem
But it is necessary that you share with the developers a .blend file scene where you can reproduce the problem.

The new version helped but only if I load the basic setup. If I copy setup from 2.90.1 it does this same thing. I didn’t install any addon even from the already build in or change any settings so that’s interesting.

First, the problem wasn’t solved. After a fresh instal, my GPU wasn’t active, after enabling it, weird stripes and darker tiles still appeared. But I don’t know should I call it a bug or my stupidity. My area lights were too small and by that, I mean like few millimetres (in properties, not the scaling light). Making them bigger solved the problem.