GPU Rendering anything on Cycles = Crash

16gb DDR4 Ram
I7 7700k
GTX 1080 Ti

Hi all!

My scene crashes any time I try to go into rendered view - or try to render an image.
I have MANY details and have tried MANY things, which I will list here. I was really hoping to find a fix for this because I’ve seen people with similar issues here and there. I can’t imagine the scene being too complex as an issue, because that would imply that the 7700k would be more powerful than the 1080ti which… seriously man? But then, why would deleting certain of the armatures make even my GPU work? Temperatures are fine, and % load of CPU and GPU are very low until the crash actually happens (at which point CPU is at 90-100 load while GPU is basically being unused).

Here’s what works:

  • Rendering with CPU: Works.
  • Deleting a random amount of the red headed guys in the back (Normally having 3-4 is fine, but more is buggy)
  • Eevee Rendering

Here’s what doesn’t:

  • GPU Rendering with CUDA and OptiX: Fails.
  • Simplify -> Setting texture resolution to the lowest possible.
  • 0 Light Bounces
  • Decreasing resolution + Samples
  • Deleting all Add ons
  • Re-installing Blender
  • Re-installing Nvidia Drivers
  • Updating Windows (and repairing)
  • Editing Tdr delay or whatever it’s called
  • Reverting to Blender 2.78 (file crashes upon opening)

Thank you for reading!
This is an important project for me, so I really hope we find a fix soon.

I removed the attached blend file for personal reasons.

If it gives you and error, your scene may be too big to load all geometry and textures into the GPU memory. The CPU uses system memory, of course, and in general you have a lot more of that available. There is a way to use out of core memory, or will be, but for now, CPU has to do to render large scenes. CPU rendering is better in some ways due to the precision of CPUs v GPUs, some CPUs can be faster than the GPUs out there, in my case my Ryzen 1700 is faster than the GTX 970, but this will not always be the case for sure. Take note of the error presented to you during the crash so we can help.

The error is simply that it crashes - no error or anything. Just not responding.

I hit rendered view, and then it crashes - or if I render the image as well.

I don’t think it has to do with my scene either, because I use to be able to render this scene with no problems in previous versions of blender. If I use an older version of this file (which has the same exact models and materials etc just different animation information), then it works fine too. :confused:

Hi all!

I was able to find a fix.
For me it seemed not to be a problem with textures - but a problem with certain shaders. The velvet in particular seemed to cause issues.

I also removed ALL principled shaders and any node that went into displacement in the material output and DELETED them, not just disconnected them.

I did this for a large number of my models, and now everything seems to be working. I didn’t have to remove any geometry etc, or simplify the scene even slightly.

TL:DR - It’s probably memory issues. Just use simple shaders ONLY and refrain from any image texture nodes, velvet shaders, or principled shaders. This is what worked for me, which is very unfortunate. But, there are work arounds. Thank GOD I can continue working on this project!!! I’m so happy!