GPU Rendering issue “Cuda error at cuCtxCreate: Illegal Address


Trying to bake an AO 2048 x 2048 on a relatively simple asset

I can bake on cpu but GPU I get this error.

Any idea? I have a buttload of ram on the card, 13gig If I recall so I shouldn’t have any problems with memory surely?

I just tried it on a basic cube too and it fails…

I had the same problem, you probably have a corrupted cuda kernel…

It’s funny you mentioned that. There was an update for manjaro just, about 1.3 gigs worth. noticed there was a cuda update along with loads of nvidia stuff.

Just tried it again and it works. But im a little unsure about the settings.

Is GPU rendering enabled do you think?

I only ask because the gpu/cpu rendering toggle on the right is grayed out on the GPU rendering option. I can still set it to glsl on the preferences so it should be working right?

In the preference panel, Cycle compute device: none

And render panel is grayed out, so, not, no gpu rendering i guess.

Did you reboot after the upgrade ? Have to reboot on Arch when nvidia drivers are updated before being able to use GPU acceleration again.

ill reboot now, just noticed the ‘none’ too

ok, that fixed the gpu rendering, but still have a problem with the ao bake

Will try downloading direct from blender site like you suggested, I know this sounds silly but not sure how to go about that on arch based system. so used to clicking the AUR

Blender from the official site is straightforward, no need to install it.

Uncompress it somewhere, open a terminal, go to the directory, ./blender

done…and it works! can bake ao with gpu now.

many thanks!

was kinda hoping it would fix this problem…but it hasn’t. but im still happy

If you want to keep using Manjaro’s blender, you’ll have to replace kernel from the one officials. On arch, it happened a couple of time, then got fixed.