GPU Rendering Issue - Tiles Rendering Different Colours

Hey all,

In need of some help!

I have an issue when rendering using GPU. The colours and materials are fine when in rendered view in my viewport. When I hit render, some of the tiles render out a different colour (in this case, the gold renders pink) but when I switch to cpu, the problem disappears. My other projects are rendering fine using GPU.
Card is a 1080ti.

Thanks in advance.

Is this 2.79b or a more recent 2.79 build? If you haven’t, can you try a current 2.79 build from

Can you post a .blend file that reproduces the issue?

I experienced something like that in 2.79.6 before. It happened when using cpu+gpu renderng and some tiles (presumably those rendered by the gpu?) were different in luminosity than the rest of the image. Never happened in 2.79b.

It was an older version but I’ve downloaded the most recent build and I’m still having the same issue. Not other project is doing it so it must be a setting somewhere to do with the GPU.
I’ll try and get a .blend sorted tomorrow that has the issue. I can’t share this one unfortunately. Appreciate the help.

Yeah sounds like it could be the same problem. Frustrating. I might switch back to a previous version and see if I get the same issue. Cheers for replying.

Normally CPU and GPU are pretty much pixel perfect identical, but it could be some numerical edge-case where a result comes out just a tiny bit different. If you change the camera angle or twiddle shader parameters a tiny bit does that have any effect, or does it seem more robustly different?

If you change the render tile size does the problem move around or disappear?

Moving the camera did actually affect it, but the colour issue was still there.
I’ve just solved it. I disconnected the texture coordinate node from the scenes HDRI and the problem has disappeared. I need to render the whole scene just to double check, but I’ll do this in morning.

Really appreciate your help.

Problem still occurs :frowning: All that the above does, is turn off the HDRI. I’ve tried different HDRI’s and different node set-ups but still the same issue.

Finally solved the issue. It seemed to be the gold material that was causing the issue. I can’t see anything wrong with it myself, can anyone else? But anyway, it’s all working fine now that I’ve swapped the material.

Problem material

Not that I think it matters, and I don’t find any direct mistakes per se, but I would drop the mapping node and use noise scale 800 instead. I’d also use the fac output.

Most likely unrelated, but try adding another noise node with the same values. I’ve had noise node go completely bonkers for no reason.

Also, noise is an extremely uniformly distributed type of noise. Maybe explore other options?

For such high values of roughness, I would consider using GGX multiscatter, and possibly add some brighter edge color (more gold like, but it’s an artistic choice).

You mentioned the graphics card, but not the system. I can’t help you as I don’t have GPU at the moment, but if you shared the project (strip it down to its bare minimum still have issues) someone might look into it. If it is an actual problem it should be properly reported.

Appreciate this, thanks. The issue has risen it’s ugly head again but this time I’m getting random blue tiles on another object in the scene. I’m currently exporting the scene to import into a fresh blend file to see if a setting has been changed accidentally, but I’m not hopeful.

I’ll make the changes above, all makes sense. I’ll also try replacing the noise node too, cheers. Although the colour change seems to fill a render tile and all objects/space in it.

Again, thanks for the tip for the roughness. Need to explore those settings more. I may upload a .blend if I can’t solve the problem by the end of the week.

Care to share the problematic fraction of the scene to investigate & debug?

Yeah I think it’s at that point. Still can’t figure it out.

What’s the process of packing all the textures, materials, objects etc. into the .blend file so you guys have everything?

File menu: Save As … some new file you want to share.
In 3D view: Object/Relations/Make Local/All.
Then menu: File/External Data/Pack All Into Blend.

If you clean up everything and has nested node groups etc, you should do multiple “Outliner/Orphan Data/Purge All”, Save, Revert.

Here’s she is:

If the render border is still active, when you hit render it’ll render the bottle and you should see the issue pretty clearly.

Reproduced here. (Edit: Windows 10, Nvidia 1060 6GB).

It actually crashes Cycles at 40+% complete when using a recent 2.79.6 build:

2019-01-17 10:46:40,360 WARNING: The lab is not designed to work with unstable Blender build (2, 79, 6)
Address : 0x00007FF730050BC0
Module : C:\Users\Gavin\Desktop\blender-2.79.0-git.cac3e16cfb76-windows64\blender.exe

The first tile is probably going to the GPU and that’s the blue one. If I change tiles size to 64x64 it’s clear that all the GPU tiles are blue while the CPU tiles are not-blue. This proceeds a substantial way through the render until it crashes again.

GPU only produces an entirely blue bottle and the render completes successfully.

CPU only produces an entirely not-blue bottle but crashes when there are no new tiles to start rendering.

Trying it in 2.80 current gives pretty much identical results to current 2.79 (not surprising as they use the same version of Cycles).

Also in 2.80 it gives:


And sits idle for 90 seconds before starting the render sequence.

That’s a surprisingly heavy file. There’s a ton of 8k and 6k textures in there and some ludicrously complicated shader trees. perhaps a round of simplification could help smooth over some of the rendering issues you’ve been having. (seriously, that dispersion glass shader still looks like trash after 2500 samples, and it doesn’t appear to add much to the scene once it gets more resolved. Perhaps a simpler glass shader would do the trick and render faster)

That being said, I can render this scene on a quadro k4200 with my gpu and cpu with no discernable difference in the tiles.

Interesting. I didn’t think about changing the tile size. I can complete the whole render but obviously has all of the miss-coloured tiles. The blue seems to of replaced the earlier pink tile issue.

@SterlingRoth I agree it’s a heavy file. It’s my first time creating glass and I was following along with a Gleb Alexandrov tutorial to get some pointers as the glass shader was giving pretty unrealistic results. I tend to use larger textures because sometimes the final image is rendered out at 8k (product visualisation), so it needs to look good blown up. I’m maybe in need of an upgrade. Also, I heavily subsurfed the glass to use displacement for the Boss logo. I think that’s one of the main contenders.

Are you saying you’re not getting the blue tiles? It’s all clear?

Versions of Cycles that support CPU+GPU are fastest for any GPU-related rendering at very small tile sizes, often 16x16 will be the fastest. This is even for GPU-only before you factor in the need for small tiles with CPU+GPU rendering to avoid giving too much of the work to slower CPU threads. Your scene currently is set up with old 2.79 style ~256x256 tiles I believe which will be significantly slower with modern Cycles.

Oh wow, ok. Stuck in the stone age. I’m using an addon to auto detect the ideal tile size but must be outdated then if that’s the case. I’ll give it a go.