GPU Rendering Issues (OpenCL, blender 2.92)

I’m trying to render a moderately complex scene, and I’m really struggling to get my GPU to behave. Currently using an rx 5600 xt w/ i5-9600k, on windows 10, amd driver 21.2.2, blender 2.92 (outdated but more stable w/ blender as I understand.) The scene includes hair physics and smoke physics, but the water is just a normal map. Here’s a screenshot of the scene for reference:

When I perform a cycles render with the GPU enabled I’m getting render times of ~5 mins+ (60 samples, 12 bounces (6,6,6,12,2), 256px tiles), however on CPU I’m getting render times of ~3 mins (60 samples, 12 bounces (6,6,6,12,2), 32px tiles). I feel like the GPU should be performing much better and I’m really not sure where my issue lies.

Things I’ve tried to optimize my render:

  • Adjusting tile size
  • Reducing bounces (any lower and I start getting fireflies)
  • Reducing the resolution of physics sims
  • Playing w/ hair BVH (little/no impact)
  • Tested the newest amd driver 21.3.1 (complete instability)
  • Enabling / disabling the CPU as a render device when doing GPU rendering (little/no impact)

I understand this is a pretty broad question, but if anyone has had a similar experience or renders with AMD gpu’s let me know, any insight is appreciated! (I also ran the BMW27 benchmark w/ openCL and it performed exactly where it should, leaving me to believe the issue in my render settings)