GPU rendering with vector pass / physical memory usage issue

If I render a scene using my GPU with vector pass enabled, I get a windows “out of memory” error after 10 to 12 frames are rendered and eventually the GPU will also quit with a similar error… is that a known issue, is there a way around it, if I switch to cpu this does not seem to happen.

I tried rendering the animation with the resources manager (win7 pro 64bit) open and observe that with every frame rendered physical memory use grows rapidly, but very little is released, if any, when rendering a frame is complete and as said, this continues until windows complains and shuts blender down

I have also rendered to the 9-10 frame limit I experience and blender will not release the memory used when the job is done unless you close it.

if needed I can upload a file, but I have had this issue with a box(six faces, no textures) in a tracking scene so i doubt the issue will be found in my blend

System info

Operating System: Windows 7 Professional, 64-bit (Service Pack 1)
DirectX version: 11.0
GPU processor: GeForce GTX 580
Driver version: 350.12
Direct3D API version: 11
Direct3D feature level: 11_0
CUDA Cores: 512
Core clock: 855 MHz
Shader clock: 1710 MHz
Memory data rate: 4212 MHz
Memory interface: 384-bit
Memory bandwidth: 202.18 GB/s
Total available graphics memory: 8955 MB
Dedicated video memory: 3072 MB GDDR5
System video memory: 0 MB
Shared system memory: 5883 MB
Video BIOS version:
IRQ: 16
Bus: PCI Express x16 Gen2
Device Id: 10DE 1080 15883842
Part Number: 1261 0002

Hi, you cant use this “Total available graphics memory: 8955 MB” you can use only 3 GB of your GTX 580 -System/display.
The growing memory is RAM and if Blender running out of RAM it Crash.
Try to switch off Undo in User Preferences or limit it´s RAM usage.
You can do nothing when you run out of GPU memory.
Make sure you are not use “Experimental” in render settings, it use much more memory than “Supported”.
I sold my GTX 560Ti 1.28 GB card because it cant even render the default cube in “Experimental” setup.

Cheers, mib

thanks for the advice, but still, for my education, why does this occur with vector blur enabled for GPU render?, because it doesn’t happen if I use CPU render “too slow” and the scene will render fine on the GPU if I disable my vector pass, I am simple trying to understand what is going on, to solve it or find a work around.

even with the memory issue I get those 10 frames from the GPU faster than I get 1 frame from the CPU…the render time is a real killer for me :frowning:

I eventually rendered the vector pass to a file output as exr using cycles on the CPU, which seems to be 2x faster than rendering the pass with blender internal, even done as a file output memory doubles every frame effectively starve my system of resources if I use the GPU …12GB just gobbled up by 10 frames,

my test is only 100 frames and took 8hrs+ rendering with the CPU, looked all over and still could not find any info on the proper use “if any” of vector pass with GPU rendering, I don’t come here often so I miss a lot of info here and google hasn’t been helpful

Hi again, can you upload the file?
I don´t use path often but it cant influence memory so much.
May other user can look in to too.

Cheers, mib

it still won’t render more than 10 frames with the vector and z passes rendered out as image sequences …weird need to finish my test scene so I am rendering the animation to image and will composite the images together in internal or something…cycles GPU rendering has real issues with vector pass…on my pc at least.

here’s sample file

well I have gotten it done by rendering the truck animation on the GPU to an image sequence and the depth and vect passes on CPU then compositing the images, but as stated above cycles will soak up all my system memory even with the vector pass is rendered to images and applied to the render layer directly

Hi, just small report, I have no problem to render your file.
Tested with 20 samples, 100 frames on GTX 760 4 GB.
Ram never goes over 900 MB during render with Z and Vector pass.
System specs in signature.

Cheers mib

well I can’t imagine what issue could be on my end, wll render at twenty samples, then reset blender to factory and try at 100 again…see what happens…is there a setting that may cause blender to hold data in memory, for any reason

also did u render the animation that’s not clear from what u said, thanks

reseting to factory seems to have done the trick, though apart from the theme and enabling cycles on the GPU, and switching to left mouse I don’t change anything else…ever so often, I increase caching for video footage manipulation but that’s it weird

anyway will try to narrow down the cause further

didn’t save the factory setting, reopen blender with my normal setting intact and now it renders without issue, seems like somewhere along the line, either temporary setting change by me or something done in the settings by blender itself causes to issue have no clue which…but at least I know now that flushing my preferences fixes it

eventually had to redo the preferences as the problem returned…still, strange that a setting is causing such instability