Grabbing keyfame points distorts them -blend added

Whenever I press ‘g’ to move some keyframe points, they become very slightly distorted, is there any way past this?
TS

Edit: they are NOT snapping to markers

http://dl.dropbox.com/u/10860244/problem.jpg

http://bit.ly/HsPGXR

Keyframes by default snap to the nearest frame when grabbed & dragged. I can’t see your Timeline scale but this seems likely. If you want inter-frame values on the X-axis, try entering them in the Properties fields for a currently selected key.

You can also do keyframe moves using keyboard input, with key sequences like G,X,10 (<Grab, constrain to X-axis, 10 frames in the positive direction)

Nope, they are already on frames, (this is about a 4000 frame scale) Any other ideas?

Not without more info or a file to look at. Do these distortions occur on unselected keys when moving some other key, as your screenshot seems to indicate?

EDIT: here is the link - the object with the keys in question is selected:
http://bit.ly/HsPGXR

Very weird. When I first open the file, select all the keys and drag in X, I get the behavior you describe. The keys are moving one frame at a time, but not in synch with one another, which isn’t right at all. But after cancelling the Grab with the RMB, and trying again, everything moves as it should. I also found that changing such options as Time Snap type, Interpolation Mode and Handle Type will “kill” the glitchy key movement. Maybe submit a bug report? This doesn’t look like proper behavior, and if it persists for you, it’s definitely in need of correction.

This is probably partially caused by the “snap to nearest second” stuff (since timing is shown in seconds here). However, it definitely looks a bit weird.

@ Aligorith – I tried changing the snap options, and every time I did, it fixed the issue. It was only when I first tried to drag the keys that they glitched.