Gradient fill occurs after using Skin Faces/Edge-Loops


I have another lame newbie question. Couldn’t find the answer on the forum.

I have discovered on this forum that I can bridge two faces by selecting the faces in edit mode and then pressing the F key and selecting ‘Skin Faces/Edge-Loops’. That works well. However the resulting new faces seem to have a gradient shade applied to them which is also shown when I render. Why is this and how can I get rid of it? I began my object with a plane which I then extruded so I don’t know if that is causing the problem.

No, just tried creating a cube, duplicating and then doing the same thing to join two faces and had the same issue.

You might have some of the face normals facing the wrong way. try selecting all faces in edit mode then Ctrl+N.


the faces created with the skinning functions are automatically smoothed. Select the faces and press the ‘set solid’ button in the ‘links and materials’ panel under ‘Editing (F9)’

The normals were fine, it was indeed a matter of using the Set Solid option. Thanks a lot people! Another Blender mystery solved.