Grainy image in normal engine?

I was working on a model, and even in the normal ‘Blender Render’ engine, I get a grainy image, I was rendering it using cycles and wanted to compare it with the normal render engine. I can’t seem to post a picture though, I noticed that when I turn off ‘Ray tracing’, I get a clean render, but it doesn’t look too well, but when I turn it on, it gives me a grainy image, is there any solution (like how we can increase the samples in Cycles?)

I believe its under the world tab, under gather… you should be able to up the amount of samples needed.

Edit: if you need to match the two renderers… i believe if you put bounces to 0 in cycles, this is how BI acts with illumination.

Thanks! :smiley:
I tried that and realized it didn’t change anything, then I noticed that it only happened in a specific material (Glass) I took a look at its settings and found out that it wasn’t coming out right because the gloss wasn’t set to a good value :stuck_out_tongue: