Graphics Card Not Fully Used When Rendering

I recently upgraded my hardware to the following (custom built PC):

Motherboard: AMD Ryzen A520 Aorus Elite
Processor: AMD Ryzen 7 3700X
RAM: Corsair Vengeance RGB Pro 16+16 GB
Graphics Card: Nvidia GeForce GTX 1650 4GB
SSD drive: Corsair MP600 Gen4 PCle 1TB (free space 400GB)
with Windows 10 Home

I also downloaded the updates for the graphics card from the Nvidia website:

But when rendering with Cycles, with GPU Compute option selected, it seems that major part of the rendering is still done by the CPU. Graphics card shows very low use in task manager during the render compared to the CPU. For most of the time, the percentage of graphics card’s use in the task manager is below 10%, but occasionally it jumps to 20-30% for a second or so.

The render times and use of the system parts shown in the task manager are very similar, irrespective of whether I choose CUDA or Optix in the System preferences:

Screenshot 2021-06-06 181116

Screenshot 2021-06-06 181045

But if I uncheck CPU in the preferences, the graphics card still has very low use and the render times increase 2 times.

Screenshot 2021-06-06 181315

As a side thing for testing, we put on a FPS Game on this PC, and that made a very good use of the graphics card, showing consistent 20-30% use even when paused (Blender number 1, game number 3 from top in the task manager):

Is there anything we could try to improve the performance of the graphics card for Blender rendering?

I wouldn’t trust the Windows task manager in terms of GPU usage. Instead, download HWinfo - it will show you more readings related to actual usage plus things like current clock speeds and temperature - it could be possible that the clock speed is throttling because of high temperature. You might as well find out, that everything is ok with your GPU:).