graphics not working right

hi, I’m kinda new to blender. I’ve been going through a bunch of tutorials. I have also downloaded some sample files from tutorials. when I create a scene of my own, it does not display correctly, sometime causing blender to lockup/crash. when I run the samples I have downloaded they work just fine. I’m wondering if anyone can tell me when I might have wrong. here is part of my dxdiag system specs


System Information

Time of this report: 1/26/2009, 13:09:28
Machine name: DURLON-AC5068F4
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.080814-1236)
Language: English (Regional Setting: English)
System Manufacturer: 75D8P
System Model: 775Dual-880Pro
BIOS: Default System BIOS
Processor: Intel® Pentium® 4 CPU 3.00GHz (2 CPUs)
Memory: 2048MB RAM
Page File: 1030MB used, 2977MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.5512 32bit Unicode

p.s. for some reason I cannot upload any files at all.

You forgot to say what your video card specs are =X

oops, sorry about that here is dxdiag video card specs

Display Devices

    Card name: Sapphire RADEON X1600 PRO
 Manufacturer: ATI Technologies Inc.
    Chip type: ATI Radeon Graphics Processor (0x71C2)
     DAC type: Internal DAC(400MHz)
   Device Key: Enum\PCI\VEN_1002&DEV_71C2&SUBSYS_0840174B&REV_00

Display Memory: 256.0 MB
Current Mode: 1440 x 900 (32 bit) (60Hz)
Monitor: SyncMaster 932BW/932BW Plus/BW1932/932BWE plus(Digital)
Monitor Max Res: 1440,900
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6891 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 12/1/2008 14:51:31, 318464 bytes
WHQL Logo’d: Yes
WHQL Date Stamp: n/a
VDD: n/a
Mini VDD: ati2mtag.sys
Mini VDD Date: 12/1/2008 16:13:40, 3452928 bytes
Device Identifier: {D7B71EE2-3282-11CF-106E-4A28A1C2CB35}
Vendor ID: 0x1002
Device ID: 0x71C2
SubSys ID: 0x0840174B
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel:
Deinterlace Caps: n/a
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled

does it happen even for the default scene? ATI has a bad record with the BGE. Try reinstall blender if you haven’t already.

I can run the default scene with no objects, at 60fps according to game engine. when display fps is selected. I can run a 3g gallery viewer from http://mikepan.homeip.net/games the non interactive gallery without any problems. any and all scenes that I created myself dont work properly. graphics do not display correctly. renders are ok, but game engine is not. I created a simple maze, with a cone for a actor. grass texture on maze and red color on cone. I get a bright green when running “PKEY” to test game. and bright red on cone…but cannot move the cone around at all. I did setup controls for the cone. I tried a more complex file wanting to try riggin and animating a charcter, blender just locks up whenever I push the “PKEY” to start game engine.

could you upload a .blend that doesn’t work?

sorry here is a simple maze i created. when I try to run game engine, all I see is a bright green area and a bright red cone. and controls dont work

Attachments

mazetex.blend (239 KB)

I looks the same here, you have set it up wrong (too tired right now to figure out how)… and I see no controls anywhere… and your scale is… well unusual.

Select all and hit CTRL+A to apply scale and rotation, since Sim88 said that it’s unusual.

Fixed your file (and explained what you did wrong/how to fix it) HERE (Got to it on GameBlender.org before finding it here.