Graswald - 25% OFF til 2nd of Dec

Yes, in fact you can do the same with Cycles. :smiley:

Hi, just wondering when Graswald is going to be stable with 2.80. It has been a few weeks since api freeze, but it seems Graswald is still very unreliable with 2.80. It would be a huge time saver for me (I’m doing archviz professionally), but currently the addon realiability is like a random generator.

At the moment I’m having trouble with density weights not working like they should. I have a gradient from 1 to 0 when moving away from the camera, but it seems like Graswald is ignoring the weights and also not using full density even if the weight is 1. But there are many other problems also, too many.

EDIT: Might as well report this bug: when deleting a system, I get the error message show in attached image.

Hello,

So graswald is currently being rebuilt from the ground up—there were some bugs/annoyances regarding filesize, materials being dropped, etc, that required a fundamental change in the way graswald works internally. That coupled with other changes required by 2.8 led to this decision. The current Graswald 2.8 beta (the one you have access to) has been effectively scrapped, and actually hasn’t been updated for a few months now, that was originally due to the constantly changing api and school, but now is for a different reason.

So where are we now? Over the past month I’ve completely rebuilt the way graswald manages itself, the dependencies within it, and quite a lot of other core things. At this point it is functional, but doesn’t cover all the features the 2.79 one currently has. But it is getting there. I hope to push a serious beta in about two weeks. The update will break forward compatibility with files from 2.79 and even the current 2.8, (blender already breaks backwards compatibility so what graswald does in that direction doesn’t matter). I hope to later build a converter/mode to fix this, but that will take time. We also have a package creator tool on the to-do list, and a few other things, but we are making progress.

I’ll start posting more regular updates on the graswald thread (Graswald), and will notify people here when the beta becomes available.

7 Likes

Hi,
very nice to hear, that you actively working on it!
I’m very excited to work with the fresh, more reliable version. Many thanks!
:grinning::+1:

Only 4 days left til this year’s blender conference will start and I am thrilled to see all these awesome people again. To celebrate this, there will be a 20% DISCOUNT for Graswald for Blender and the Asset Library on the Blender Market and on Gumroad during the time of the conference (24th-26th of October).

Don’t miss it!

Graswald for Blender:

Graswald Asset Library:

2 Likes

Graswald for Blender 2.80 beta v4 has been released now on the Blender Market and on Gumroad! Check it out and report bugs here: Graswald

2 Likes

Hi mate, I seem to have trouble installing the new beta. Previous was working fine. (I’m new to blender please forgive me). When I try install the zip in blender 2.80 it throws up an error, a few lines actually, as soon as I have ticked the box to use the addon in the preferences panel install addon. I removed the previous addon and even deleted it from my blender addon folder within my app data user directory. Any advice?

1 Like

This is a known issue I think. Quit Blender and reopen, then try to check the box again. Did this fix it?

Can you send a screenshot of the error?

Yep - Screenshot_1 Screenshot_2

no it didnt. I attached the error im getting in the reply to kareem :slight_smile:

2 Likes

Ok, this should be fixed if you enable the Copy Attributes Addon. I’ll fix this error in the next build.

3 Likes

That worked. Thanks mate.

2 Likes

Okay, I do indeed want to pounce on the sale and finally get Graswald, but does it work in 2.81, or is it not quite there yet, and only working in older 2.8 builds?.. I use pretty recent builds of E-Cycles Blender (currently 2.81.14) in my day-to-day work, and I am hoping that I could plug this mofo right into my E-C workflow without needing to have a separate older version of 2.8… Please advise. ; - )

Lol I’ll be the one on BA too much again and tell you.

I just bought it and tested in latest build of E-Cycles. It works like a charm once enabled but can only be enabled if you enable the “Copy Attributes” addon first as mentioned above.

2 Likes

We fixed the bug that doesn’t let you install #Graswald for 2.80 without the copy attributes add-on enabled. Go ahead and download from blendermarket and gumroad.

6 Likes

About a year ago, we started working on an implementation of Graswald for Blender 2.80. Lots of bug fixing hours later, we’re proud to officially release Graswald for Blender 2.80.

Buy/redownload on gumroad: https://gum.co/krWDF
Learn how to use it: https://youtu.be/hVRmoyCY-XE

4 Likes

Is it up on the Blender Market yet?

I think it is. I just downloaded a 914 MB file. And the page references only the blender 2.8 version whereas before it said 2.8 version is available free as trial.

2 Likes

Great work! @Yukon