Graswald - News and Work in Progress

Scratch that, found a bug where if you add an object to one scene, while you have graswald systems in objects that are selected in other scenes, all those other objects get purged. Working on a fix, and an easier way to make appending work. Nearly there.

2 Likes

I’ve got everything but physics working across scenes, should be good in a day or two.

2 Likes

Thank you very much. :slightly_smiling_face:

Hello,
I have just purchased Graswald for Blender 2.8 (Graswald_2.0_beta_3.zip, version 1.2) and I can’t figure out where I can change the quality of the texture. In the material settings part, I only have the high material version (RibwortPlantain High Cycles/Eevee for example). I am pretty sure it is obvious but I do not see it.
Does anyone know where it is ?

image

Be sure to check “Show Advanced Settings” just little down on the screenshot you posted.

Created this topic. Hope it can improve further devloppement of graswald with auto cluster, color variation and terrain displacement ?

2 Likes

Thank you for your quick response.
Even if I check the “Show Advanced Settings” box I do not see the quality settings. And the choice for material is still the same (only high Cycles/Eevee).

1 Like

I’ve had this problem too, rendered my last project with high material just because I couldn’t find the lower quality materials.

1 Like

I think I found it (not sure).
It is under the “Display” tab, in modifier settings (need to click the icon), then there is a “Mesh resolution” slide bar from 0.00 to 1.00 (1.00 is the default value).
So the name of materials in the “Material” tab is misleading since it supposes there are other types of quality (high / medium / low), whereas it seems it’s not.
image

You need to click the + button on the right, and choose the type of material you would like to load.

The drop-down that you clicked is for choosing from the materials already in the file: say you have two versions of the high material, one that is aged, and one that is young, for two different systems

2 Likes

Ok I did not click this + button… I have the choice now.
Thank you for your helpful answer.

I bought earlier version of Graswald via Gumroad, how could I get 2.80 version?
I have received two updates via email : 1.14 and 1.15 respectively, but haven’t receive the 2.80 version.

Thank you

I think you need to login to gumroad, or somehow go to the link in original receipt to download it.

Thank you very much … I have downloaded from original receipt.

Hello,
I am trying to make a large realistic landscape of several hectares full of low vegetations (and some trees) with a resolution on the ground around 5 centimeters. It is to create a landscape view from the sky, at around 50m-100m from the ground, camera facing down. I use Graswald but I am facing performance isues or bad results. Not the Graswald’s fault of course, but due to my inexperience in this subject.

Expected result is the first image at the end.

I firstly naively made a huge particule system with Graswald but despite my 32 GB RAM, Blender ran out of memory. After this logic fail I explored other techniques :

  • Full procedural textures, but I definitively do not have the level right now to achieve a realistic result. Furthermore, I am not sure it is the right way to do what I want.
  • Particule sytem with planes as particules, whose the base color textures come from previous orthograhpic renders with Graswald (it looks like a base color baking of a primary particule system). Individual planes look not so bad, but put together in the secondary particule system it is not satisfactory. The idea here is to have a particule sytem of rendered patchs of particule system.
  • Texture paint a large plane with a texture (the same one as the previous point), from a previous orthograhpic renders with Graswald particule system. The resulted image texture is way too large (>1GB) if I want to achieve my 5 cm of resolution on the ground. And above all, the result is not good.
  • Use, again, a rendered texture on a plane, and then make a lot of planes with a random texture placement thanks to random coordinate generation to break pattern repetition.

The last point is the best (but not satisfactory at all). To illustrate it, the second image is the rendered plane (represents 1m x 1m) with a particule system with Graswald (I know it lacks of diversity right now).

The nodes I use to randomly place this texture on hundreds of planes is the third image.
And the result (around 15m wide) is the last image.

On a performance point of view it is great since it does not need much memory (I mean for this large size) and shader calculation is very simple. But it is not realistic at all. It lacks variations across tiles like we can have with a standard particule system.

Nothing I have tried can beat a giant grass particule system with vertex group paintings to bring nice variations on size and distribution.

If someone have any idea or some documentation or links to acheive this large scale realistic grass landscape, I will appreciate it.

Thank you.

hello, i made a physics test in graswald and I’m having issues with the physics having a delayed reaction and clipping through

it’s hard to notice at first but the hair physics have a slightly delay between touching the sphere and reacting

It might be more noticeable here

is this normal? i tried increasing the quality steps in the hair dynamics but doing that breaks the physics and make random pieces fly away

Are you using the sphere as a collision object? You can try using it as a force field with shape: surface, and play with the falloff power. Simulations tend to take some fiddling to get right

1 Like

Yes I’m using the sphere as a collision object, I’ll try that force field method. thanks

1 Like

Hi, Thank you for a great addon

This is kind off topic, but I wanted to ask if there is a quick solution or if you know straight up that it’s impossible to get it work without some coding. Spent several hours trying to get it to work.

I am using Graswald with Octane Blender 2.79b with Octane render and it works well, just by converting Cycles shaders to Octane shaders and using Contorl_Basic to drive the node setups (of course some of the functionality is lost). Now I am trying to use Graswald II in Blender 2.8 Octane version and I think there is just a little tweak or something to get it working. In Cycles mode it works like it should. But when setting to Octane render something happens to the particle connection to the blend files.

Some images to clarify the operation (hopefully)

Octane In solid mode everything is ok

Octane in rendered mode. Only the first particle setting shows.

By converting the particlesettings modifiers everything works like it should
converting

Using the Graswald II Beta 3

I understand that this is a beta version and you are busy with the main development, but with Blender Octane render you could get more users.

I’m not quite sure what the issue is, but since octane for blender is free, I’d be willing to poke around after the 2.80 graswald becomes stable

1 Like