Graswald - News and Work in Progress

Hi. Is it possible to override the material to a white diffuse. I am sure it is, but somehow the material slot seems to be only responding to the grass material.

Found some issues and workarounds for Graswald for anyone else who’s interested:

ISSUE #1

I’m using Graswald Pro, and am working on realistic wind animation.
To get believable results, you have to use hair dynamics.
The problem is that if you want to render frames out of order (like with a render farm), you need to bake the animation to cache.
Graswald seems to have a problem with baking dynamics though.
Whenever you go to bake dynamics, the Graswald plants/grass disappear or only show the first frame. For some reason, the animation won’t bake to disk properly.

Well, I’ve discovered the issue. It’s a bug with Graswald.
If you have Graswald enabled, you cannot bake hair dynamics to disk.

These errors appear in the console:

  1. \addons\Graswald-Pro\simulation\data\callbacks.py", line 88, in func2
    func(self, psys)
  2. \addons\Graswald-Pro\simulation\data\callbacks.py", line 94, in use_hair_refresh
    for gsys in self.id_data.ggd.data.get_gsystems(self.gsettings()):
  3. AttributeError: ‘GRASWALD_PG_gsett_simulation’ object has no attribute ‘gsettings’
  4. \addons\Graswald-Pro\simulation\data\callbacks.py", line 85, in func2

As a temporary workaround, I have found that if you disable the Graswald addon in Preferences, you can then bake your Graswald hair dynamics to disk.
(I have a feeling the bug has something to do with Graswald’s “refresh” system which is interfering with Blender’s baking functionality. Disable Graswald and the problem doesn’t occur.)

ISSUE #2:

You can use the above workaround to bake Graswald hair dynamics to disk. BUT if you baked out a framerange starting with a negative number (i.e. -50 to 100), you will then NOT be able to load that cache again upon closing and re-opening your .blend file.
In order for your cache to load, you need to go into the hair system’s cache settings and set the “Simulation Start” to a non-negative number (i.e. 0 or 1). If you do that, the cache will then load and be used properly. For some reason, Graswald/Blender will not use your baked cache if you still have “Simulation Start” as a non-negative number.

Hope all this helps, either the developers so they can improve the addon, or anyone who comes across the same issues.

As a personal note, I think Graswald is a fantastic addon. The area it needs the most work though is the wind/animation system. Graswald excels at still images. But using it in animations is a real pain, and a huge struggle to make look realistic.

2 Likes

Hey there, thanks for the great feedback, I wrote you an email!

These are tough times for all of us. We want you to smile big underneath your mask so we decided to start a big sale. Go follow the link and get Graswald Pro, Graswald or the Asset Library 30% off. Because we want you to stay creative while staying at home.

3 Likes

Could someone please tell me how i can see the actual geo in the viewport without rendering.

try this for the Workbench-mode

2 Likes

Nice one, thank you.

1 Like

Hi, I’ve just purchased Graswald Pro in the corona sucks sale and i’m just trying to figure everything out.

The reason i’m posting is because when I try and change the material quality setting I get the following error message. I’ve tried with a couple of different models and get the same error. Can someone tell me how to fix this?

Also just to be clear, is this the setting to change when you want to switch from large fields (low quality) to a close up of a few models (high quality)? Is there anyway to switch automatically from high, to medium to low depending on how close the model is to the camera?

Thanks

The error is a bug, we are fixing this, expect a fix soon.

Pretty much.

As of now, no.

Graswald 1.3.2 Update is out now!

Many of you have encountered quite some bugs in the latest 2.90 Blender version. In the past, we sometimes had issues fixing bugs quickly. We take this issue very seriously and therefore not only fixed a lot of very annoying bugs in this new update, but also implemented an internal pipeline, allowing us to deal with bugs more professionally leading to more bugs being fixed in a shorter amount of time.

Thank you for your patience and support, and especially for your feedback which helped us improve this situation a lot.

Enjoy the new update and show us your work with the hashtag #MadeWithGraswald!

5 Likes

Thanks for the update and your hard work.

It seems like there still remains an issue that has already been mentioned before.
When creating a new system, the scaling of the model is to high. This might have to do with the relation between Hair Length and Object Scale in the Particle Settings. If the Scale and Hair Length are both set to one the model scale should be correct.

However, on default Hair Length when creating a new Graswald System is set to 2m, resulting in models that are too large. Actually you could easily fix that by setting the Hair Length to 1m but this value gets reseted to 2m everytime I hit final render :sweat_smile:

Hey @xrogueleaderx, the scaling of the models is actually correct. The hair-length value in blender is, unfortunately, misleading: the hair length is always 4x the normal value. The relative scale of models is render_size*hair_length*normal so to get a 1:1 scaling we set render_size to 1, and the base normal to 0.5. Also note that changing velocity scales the objects and messes with this calculation. The final calculation is more complex when accounting for orientation, but we do all required adjustments automatically.

Note default blender behavior in the attached gif:

EDIT: the reason for the hair length changing when you hit render is a result of graswald’s maintenance of proper scaling values. If you want to scale all your models up or down, you can use the overall scale in the Overall Settings window.

Also: if your belief that the models are too large is based on the physical dimensions of the plants and not the 2m value, it is true that all of the included plants naturally vary in size with region–so feel free to tweak scaling a bit, but we have created them to accurate scaling.

Hi @KareemAlgalaly, I now understand the way of calculating the final scale and that I can tweak it with the Scale slider but the overall scale on creation still feels too large. Check out the following screenshots of perennial reyegrass in relation to a correctly scaled reference (at this point no graswald settings where changed)

Cut version reaches to the ancles


And the large variant has quite broad blades

Then I converted the particles to meshes and the scale of all variants I tested was around 1.8 to 2.0 (shouldn’t it be around 1.0)


This is what it would look like with scale set to 1.0 (more proportionate in relation to the reference)

Please don’t get me wrong, I’m not trying to necessarily find a bug here. It’s just a matter of proportions and scale that looks off from my point of view and experience :slightly_smiling_face:

Hi Mate, Im getting this when trying to export as fbx using the graswald n-panel tab.

Many of you waited for another sale and here it is! We‘re excited to announce our Black Week Sale! Get 30% off Graswald Products from Friday 27th to Monday 30th of November. Enjoy nature as it’s best and create awesome artworks using #MadeWithGraswald ! Plus, to all 3ds Max users, we have a big suprise for ya :wink:

Thanks for the bug report Greg, it’ll be fixed soon in the next version.

1 Like

Is there some place we can see a release schedule?

Graswald is growing and we want you to be a part of it! We’re looking for an Add-on Developer, Technical and 3D Vegetation Artist and a Content Marketing Specialist. If you want to join us build the future of 3D nature, send us your application here: https://www.graswald3d.com/jobs

2 Likes

Hey there, not yet. We are currently undergoing quite some internal processes, but this is a good idea which we should definitely implement! I’ll discuss it at the next dev-meeting!

New year, new update. We fixed some bugs, improved the export process and freshed up hair simulation settings. All in one, Graswald is ready to start 2021 with you. Update now.

3 Likes