Graswald RELEASE

add-ons
commercial
texturing
nature
modeling

(Kareem Ahmad) #99

Ok so I’ve said before I’ll start working on porting it one the beta comes out. That’s happened, so I’ll be getting started by end of next week. (I’ve got finals next week, can’t start earlier)

I’m not sure how long it will take. I could do a basic port—just make the main stuff compatible—or I could do something more wholistic, to really integrate it with 2.8: Specialized tools, properties we couldn’t do before, perhaps even get the Eevee shaders up and running, and probably do some optimizations while we’re at it.

I’m leaning towards the second, and that will take a while.
But perhaps, once I get started, I’ll make the 2.8 version a beta—so I’ll push updates more frequently, if you want to test it as it develops, but again the full main 2.8 release will take a while.


(captainkirk) #100

Would it be possible to create a dedicated workspace or application template for it rather than a simple panel on the side? Something where you can have more controls almost like it’s a grass mode.


(Kareem Ahmad) #101

I really like that idea.

Anyone have any other 2.8 requests?


(Julius Harling) #102

Hey there, that’s only a naming issue, the add on itself is v1.14! I thought I fixed this already but probably forgot to reupload it to gumroad as well. Anyway, besides the name there’s nothing wrong IRRC.


(vianarch) #103

There is some bugs I experienced, when I copy particle system or switch to other type of grass, the new type of grass have no material assigned until I click material mode button to select shared or unique material. Also the density in viewport is not automatically show the corresponding value until I retype the same value.


(Julius Harling) #104

Today was supposed to be the day we wanted to release Graswald v1.15, but sadly, my Grandma’s WiFi decided that it didn’t want to support this plan, so instead of v1.15 release, there’s another christmas gift:

Until the 26th of December, GET 15% OFF Graswald now!

Use the discount code ‘Merry Christmas’ for the blendermarket or follow this link for the gumroad version.

Merry Christmas everyone!


Graswald
(masterxeon1001) #105

just got mine yesterday. Look forward to 2.8 adventures with you. Looks epic.


(Nitram_2000) #106

Thanks very much. Duly bought and I’ll get creating once I’m back at my machine after the holidays. I can’t wait.


(Member) #107

Gosh very awesome work you guys…


(Julius Harling) #109

So finally after it being two of the most requested additions for Graswald, wind animation and viewport optimizations are finally integrated! Go and check it out:


Enjoy!


(gopi.vfx) #110

@Yukon @KareemAlgalaly i tested new version 1.15 with b3d 2.79 & 2.79.6 in one of my machine.
Config: core i7 4790k 4.0Ghz, 16GB Ram with an old GPU GT 610 2GB.
Populating a 100m x 100m plane with Density-80% and Display draw type-Textured freezes blender and its not responding. Only 4 GB of memory and 10-15% of my CPU are utilized.
But the system gets less responsive
does Graswald needs a good GPU?
Will check with other configs after this holidays.
Can u specify the system config and Scene information for the viewport optimization demo u showed in twitter.


(Nitram_2000) #111

A quick test for forest floor creation which took about 90 minutes to get. Obviously I would still want to tweak (I would tweak until the cows come home!) but I’m seriously in love with this addon.

Looking forward to seeing it in 2.8.


(Alan) #112

So when does Graswald work in 2.8?
I bought the add on. Can’t use it?


(Kareem Ahmad) #113

Julius just added the alpha version of Graswald for 2.8 today. So you can play around with the pre-release if you already own it. (Same place as the 1.15 release)


(tallken) #114

Graswald_28_01a got error. Can add in preference. but can not active addon

mac osx blender-2.80-82e0739f6481-OSX-10.9-x86_64_emphasized text_


(gopi.vfx) #115

@KareemAlgalaly @Yukon error while enabling the addon in b2.8

ValueError: register_class(…); already registered as a subclass


(Julius Harling) #116

I think this can be solved for now if you simply close blender after installing without saving anything or enabling anything and then open blender again. After that, it should work fine (at least for me it did).


(gopi.vfx) #117

@yukon not working for me, receiving the same error as @tallken mentioned AttributeError


(tallken) #118

not working for me . :disappointed_relieved:


(Kareem Ahmad) #119

Julius’s fix is for the “already registered” error
As for this “no user_preferences” this was reported and has to do with an API change in the newest 2.8.
I’ll fix this today.