Graswald


(Julius Harling) #362

I think this can be solved for now if you simply close blender after installing without saving anything or enabling anything and then open blender again. After that, it should work fine (at least for me it did).

We had the same error over in the other thread, this is what (for now) solved it for me.


(gopi.vfx) #363

@yukon not working for me, receiving the same error as @tallken mentioned AttributeError


(Nitram_2000) #364

This is great. Quick question, about hat sort of system are you using?

I’m doing a test of animating the age of the grass to see if I can simulate a kind of season change and a single frame on low poly mode, 100 distribution, and 500 samples at 720p is taking around 15 minutes.

I’m rendering on an NVIDIA 1070 Gtx.

Any tips for speeding up renders?

Also, I’ll second what the guys above are requesting. Some sort of large scale setup would be great. A kind of built in ‘distance from camera’ detection that picks which model to use automatically would be a lethal addition.

Until then, time to build manually :smile:

Keep up the good work!

Herzlichen Dank!!


(Nitram_2000) #365

What are mesh LOD’s? Just curious as larger scale systems are also something I’m interested in.


(Kareem Ahmad) #366

Number one tip for speeding renders is switching from high to medium material. Unless it’s a close-up you can’t tell a difference, and it saves a decent amount of time.


(Kareem Ahmad) #367

Lower resolution meshes for plants father from camera. I haven’t found these to actually help with Graswald render-times though. Anyone have any idea why?


(Nitram_2000) #368

Thanks for the speedy replies.

I also found that the materials for “Generic Grassblades - Green” and “Wall Barley - Big” aren’t working correctly for the high res models.

I’ll post any more bugs I find as I make my tests.

Edit: Blender 2.79b and Graswald 1.15, bought from the Blendermarket.


(Dodododorian96) #369

the trick dont work for me

did they modify the API even after they said they will not do it after the beta release ?


(Kareem Ahmad) #370

Yes they did, I have a fix, will get Julius upload it later. Probably tomorrow.


(Julius Harling) #371

Did you test it with a decimate modifier turned on or did you actually applied the modifier? And how strong was decimation? I’m not sure but maybe the modifier still stores the original information and therefore, the optimization is only limited?


(Kareem Ahmad) #372

I don’t think I ever applied the modifier. I’ll definitely try applying it.


(Abnehmen) #373

Wow that is great


(Kareem Ahmad) #374

Could you elaborate on what you mean by not working? I found a bug in the medium generic grass material that kept advanced settings from showing up, but didn’t notice anything with high materials or the other plant.


(Nitram_2000) #375

It seems as if something within the material itself is not plugged in correctly. It looks like only the diffuse map is connected correctly.

I’ll try and repeat it later and add some screenshots when I’m at my workstation.


(Nitram_2000) #376

Ok, I tried to recreate it and I realised that it’s the “Optimized Display” function that was actually working :slight_smile:

But, I would add that it only works with the high res models. The Middle and low res models are not affected.


(jachtarfranko) #377

I would like to ask, if 2_8 version is working now.
Because for me is not.

Thanks


(Julius Harling) #378

What do you mean with it’s not working? Because it should. Are you sure, that you installed the 2.8 version? @Nitram_2000 What do you mean with high res models? High res materials? Because as far as I know, there are no LODs implemented yet…


(jachtarfranko) #379

After activation plugin…

v Graswald_28_01a.zip


(kyraneth) #380

I’ve been having the same issues with activating the plugin in 2.8


(Nitram_2000) #381

Hi Julius,

Firstly, I’m on 2.79b, not 2.8.

What I first thought was an error seems to be a feature, but only applied to the high res models.

I created a particle system on a sphere, then I created another sphere and added the exact same system except I changed it to a medium res model.

When I click on the Optimised Display checkbox, only the High res materials are affected.

Here’s a screenshot to help you better understand what I mean.

I’m just curious if this is only supposed to effect the high res option and nothing else.

If so, then it works fine, if not, then it’s not working.

EDIT: - Yes, I mean the materials. I kept referring to models when I was changing the Materials settings. Apologies.